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1. Conventions and Availability 

This User Guide shows how to install and use the various attributes of the SAnDReS 

program (Version 2.0.0). This guide includes the capabilities of the program, how to 

apply these capabilities, and how to install SAnDReS on Linux and Windows OS. 

Here, we have the following typographical conventions: 
 

Arial font with italic 
 

Indicates filenames, folders (directories) in the main text and commands in the 

SAnDReS menu. 

Courier New font with Italic 

 

Used for Linux/Windows commands, PDB listings, and data to be typed by the user. 
 

SAnDReS is open-source software and freely distributed under GNU General Public 

License v3.0 (GPL-3.0 License). Its code is available to download on GitHub 

(https://github.com/azevedolab/sandres). 

In the following sections, we describe the installation guidelines and four tutorials 

showing how to use SAnDReS for machine learning and docking simulations. 

https://github.com/azevedolab/sandres
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2. Introduction 

SAnDReS (Statistical Analysis of Docking Results and Scoring functions) draws 

inspiration from several protein systems we have been working on in the last 

decades. These projects began in the 1990s with pioneering studies focused on 

intermolecular interactions between cyclin-dependent kinase (CDK) (EC 2.7.11.22) 

and inhibitors (de Azevedo et al., 1996; de Azevedo et al., 1997). SAnDReS is a free 

and open-source (GPL-3.0 License) computational environment for the development 

of machine-learning models (Bitencourt-Ferreira & de Azevedo, 2019; Bitencourt- 

Ferreira et al., 2021; Bitencourt-Ferreira, Rizzotto et al., 2021) for the prediction of 

ligand-binding affinity (Xavier et al., 2016; Bitencourt-Ferreira & de Azevedo, 2019; 

Veit-Acosta & de Azevedo, 2021). We developed SAnDReS using Python 3 

programming language and SciPy, NumPy, Scikit-Learn (Pedregosa et al., 2011), 

XGBoost, and Matplotlib libraries as a computational tool to explore the Scoring 

Function Space (Heck et al., 2017; Bitencourt-Ferreira & de Azevedo, 2019). 

This version is a new software with the same goal. SAnDReS explores the Scoring 

Function Space using the machine learning methods available in Scikit-Learn 

(version 1.0.2). SAnDReS 1.0 generated machine learning models based on nine 

regression methods only. It had a fixed polynomial scoring function set that used 

three features to generate up to 512 polynomial equations taking squared and mixed 

independent variables (x2 and x.y) (Xavier et al., 2016). SAnDReS 2.0 has 64 

regression methods, with no limitation in the number of features used in the machine 

learning models. SAnDReS 1.0 used AutoDock Vina 1.1.2 (Trott & Olson, 2010), now 

we have the most recent version, AutoDock Vina 1.2.3 (Eberhardt et al., 2021). 

There are a lot of minor modifications, but these previously highlighted are the most 

important ones. 

SAnDReS 2.0.0 brings together the most advanced tools for protein-ligand docking 

simulation and machine-learning modeling. We have the newest version of AutoDock 

Vina (Trott & Olson, 2010; Eberhardt et al., 2021), available in March 2022 (version 

1.2.3), as a docking engine. Also, SAnDReS 2.0.0 uses the latest version of Scikit-

Learn, available in March 2022 (version 1.0.2). SAnDReS predicts binding affinity for 

a specific protein system with superior performance compared against classical 

scoring functions. In summary, SAnDReS makes it possible for you to design a 

scoring function adequate to the protein system of your interest. 

You need Python 3 installed on your computer to run SAnDReS 2.0.0. In addition, 

you need Matplotlib, NumPy, Scikit-Learn, SciPy, and XGBoost. It is also necessary 

to have MGLTools 1.5.7 (Morris et al., 2009). You can make the installation of Python 

packages faster by installing Anaconda. 
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3. Installing SAnDReS (Linux) 

You should type all commands shown here in a Linux terminal. The easiest way to 

open a Linux terminal is to use the Ctrl+Alt+T key combination. 

 
 

Step 1. Download MGLTools 1.5.7 (https://ccsb.scripps.edu/mgltools/downloads/). 

Type the following commands: 

cd ~ 

cp Downloads/mgltools_Linux-x86_64_1.5.7_install . 

chmod u+x mgltools_Linux-x86_64_1.5.7_install 

./mgltools_Linux-x86_64_1.5.7_install 

 

 
Step 2. Download Anaconda Installer for Linux 

(https://repo.anaconda.com/archive/Anaconda3-2021.11-Linux-x86_64.sh). Go to the 

directory where you have the installer file and type the following commands: 

chmod u+x Anaconda3-2021.11-Linux-x86_64.sh 

 

./Anaconda3-2021.11-Linux-x86_64.sh 

 

Follow the instructions of the installer. 

 
 

Step 3. To run SAnDReS properly, you need Scikit-Learn 1.0.2. To be sure you have 

version 1.0.2, open a terminal, and type the following commands: 

python3 -m pip uninstall scikit-learn 

python3 -m pip install scikit-learn==1.0.2 

 
 

Step 4. To install XGBoost 

(https://xgboost.readthedocs.io/en/latest/install.html#python), type the following 

command in a terminal: 

python3 -m pip install xgboost 

 

 

Step 5. Download SAnDReS 

(https://github.com/azevedolab/sandres/raw/master/sandres2.zip). Copy the 

sandres2 zipped directory (sandres2.zip) to wherever you want it and unzip the 

zipped directory. 

Type the following command: 
 

unzip sandres2.zip 

https://ccsb.scripps.edu/mgltools/downloads/
https://repo.anaconda.com/archive/Anaconda3-2021.11-Linux-x86_64.sh
https://xgboost.readthedocs.io/en/latest/install.html%23python
https://github.com/azevedolab/sandres/raw/master/sandres2.zip
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change to sandres2 directory then, type: 
 

python3 sandres2.py 

 

 

Now you have the GUI window for SAnDReS 
 

 

Figure 1. SAnDReS Main Menu (Linux Version). 

 
 

That’s it, good SAnDReS session! 
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4. Installing SAnDReS (Windows) 

Step 1. Install MGLTools 1.5.7 (https://ccsb.scripps.edu/mgltools/downloads/). 
 

Step 2. Install Anaconda (https://www.anaconda.com/download/). Click on the 

Windows Start Menu icon and select the Anaconda prompt. From now on, insert all 

commands in the Anaconda prompt. 

Step 3. To run SAnDReS properly, you need Scikit-Learn 1.0.2. To be sure you have 

version 1.0.2, open an Anaconda prompt, and type the following commands: 

python -m pip uninstall scikit-learn 

python -m pip install scikit-learn==1.0.2 

Step 4. To install XGBoost 

(https://xgboost.readthedocs.io/en/latest/install.html#python), type the following 

command: 

python -m pip install xgboost 

 

Step 5. Download SAnDReS 

(https://github.com/azevedolab/sandres/blob/master/sandres2_win.zip). Copy the 

sandres2_win zipped directory (sandres2_win.zip) to wherever you want it and unzip 

the zipped directory. Open the Anaconda Prompt, and cd to sandres2_win directory 

then, type: 

python sandres2.py 

 

Now you have the GUI window for SAnDReS. That’s it, good SAnDReS session! 

https://ccsb.scripps.edu/mgltools/downloads/
https://www.anaconda.com/download/
https://xgboost.readthedocs.io/en/latest/install.html%23python
https://github.com/azevedolab/sandres/blob/master/sandres2_win.zip
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5. Tutorial 1. Cyclin-Dependent Kinase 2 with IC50 Data 

In this tutorial, we will generate a machine learning model to predict binding affinity 

for cyclin-dependent kinase 2 (CDK2). The idea is to use the experimental 

information (crystallographic and IC50) and build a machine-learning model. 

We will carry out docking simulations applying SAnDReS to the CDK2 structures. We 

will perform statistical analysis of these docked structures evaluating docking 

accuracy (DA) and the root-mean-squared deviations (RMSD). Also, once SAnDReS 

created a machine-learning model based on the crystallographic structures, we will 

evaluate the ranking of poses using this new scoring function targeted to CDK2. 

We consider that you have successfully installed SAnDReS as described in the 

previous sections (Section 3 and Section 4). We captured all images used to 

illustrate this tutorial running the Windows version. The overall sequence is the same 

for the Linux version. 

In this tutorial, I used the SAnDReS 2.0.0 installed on C:\Users\Walter\sandres2_win 
 

Open an Anaconda3 Prompt and cd to sandres2_win directory. For Linux, cd to the 

sandres2 directory. Type the following commands: 
 

cd c:\Users\Walter\sandres2_win 

python sandres2.py 

It is necessary to use the directory you have SAnDReS on your computer. 

Upon starting the program SAnDReS, you have the following GUI. 

 

Figure 2. SAnDReS Graphical User Interface (Windows Version). 

 
 

In the rest of this tutorial, we will show the running of all necessary tasks through the 

above GUI. 

Note. After SAnDReS installation, we have the following folders in the sandres2_win 

directory (sandres2 for Linux): datasets, Ligands, misc, MLRegMPy, and tools. The 

last two folders have Python codes used by SAnDReS. We find auxiliary files 

necessary to run SAnDReS in the misc folder. We keep the project directories in the 

dataset folder, one project directory for each protein system (e.g., CDK2_IC50). In 

Tutorials 1 and 2, we need files found in the Ligands folder. 
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5.1. Tutorial 1. Setup 

Here, we will download the ligand databases and define the project directory. 
SAnDReS has predefined ligand databases with experimental binding affinities (Ki, 
Kd, and IC50) and generated PDBQT files for ligand structures. We used the affinity 
data available in the PDBbind (Wang et al., 2004) to generate these databases. The 
project directory is where SAnDReS keeps all files generated during its execution. 
We expect one for each protein system. 
Click on Setup->Check Ligand Datasets, as shown below. 

 

Figure 3. Dataset Menu (Windows Version). 

 
 

SAnDReS will show the number of ligands in the databases. As we can see, we have 

zero ligands in the databases. SAnDReS communicates with you through the 

message bar, right below the SAnDReS logo. 
 

 

Figure 4. Main Menu with information on the message bar (Windows Version). 
 

To download the ligand databases, click on Setup->Download Ligand Databases 

(IC50, Kd, Ki). Click on the Yes option. After finishing downloading, you get the 

following message: 

SAnDReS updated Ligand Databases! 
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Next, we will enter the project directory. 
 

Click on Setup->Project Directory->Enter Project, as shown below. 
 

 

Figure 5. Dataset Menu (Windows Version). 

 
 

SAnDReS will open an editor (Fast Editor), and you should insert the directory where 

we will have all data related to this modeling, as shown in Figure 6. With this 

approach, we have a project directory for each protein system. 
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Figure 6. Fast Editor (Windows Version). 

 
 

After writing the project directory in the Fast Editor, click on the Save button and 

Close button. I recommend creating your project directory in the datasets folder. For 

instance, you want to create a project directory named CDK2_IC50. You type the 

following string in the Fast Editor: 
C:/Users/Walter/sandres2_win/datasets/CDK2_IC50/ 

Do not forget the final slash /. 
 

Then, you click on Setup->Project Directory->Make a New Project. Click on the Yes 

option. SAnDReS will generate a new directory named CDK2_IC50. You should get 

the following message: 

Successfully created the directory 

C:/Users/Walter/sandres2_win/datasets/CDK2_IC50/ 

 

 
Now, we finished the Setup. For this tutorial, you do not need to interact with the 

other options of the Setup Menu. 

Note. During a SAnDReS session, we keep all graphic files in the plots folder of the 

project directory. SAnDReS saves all downloaded PDB files in the pdb folder of the 

project directory. We find generated PDBQT files in the pdbqt folder. 
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5.2. Tutorial 1. Dataset 

In this part, we will download crystal structures from the Protein Data Bank (PDB) 

and select the binding affinity data. We will generate PDBQT files for all entries in the 

dataset. 

Click on Edit->Parameters->Project Summary. This part is not mandatory is only to 

add some description about this dataset. With this task, SAnDReS edits a file named 

summary.txt. You may add some explanation, for instance: CDK2 with IC50 

data. After adding this sentence, click on Save button and Close button. 

Now, click on Dataset->Enter PDB Access Codes. You will have the following 

screen. 
 

 

Figure 7. Fast Editor (Windows Version). 

 
 

Now, you Ctrl C the following PDB access codes and Ctrl V to the SAnDReS editor. 

You may download the pdb_codes.csv file by clicking here. Save it in the project 

directory. 

3IG7,3WBL,2VTH,3IGG,2VTA,2VTP,2VTO,2VTN,2VTM,3R8V,2VTL,3R8U,2V 

TI,4LYN,3UNJ,3QTZ,3QTX,3QTW,4EZ3,3TIY,3QTU,1PXL,3QTS,3QTR,3QTQ 

,3QU0,2W17,3TI1,1Y91,1G5S,1PXK,2W1H,5D1J,3EZV,2W06,2W05,3EZR,2 

A4L,1V1K,3LFN,3QQK,2R64,3RAH,2B52,1W0X,2B53,2B55,1R78,2C6I,2C6 

K,3RAL,2C6L,2C6M,3RPY,3RPV,2BTR,1P2A,2BTS,3FZ1,2UZO,2UZN,2R3M, 

2R3N,2R3O,3S2P,2R3G,2C5Y,2R3H,2R3I,2A0C,3S1H,1DI8,4ERW,3SQQ,3S 

0O,3PJ8,2DUV,3RNI,4RJ3,1KE5,1KE6,1KE7,1KE8,3RMF,1VYZ,3PY1,3PXZ 

,4GCJ,2VV9,3NS9,3RK9,3RK7,3RK5,3RKB,2VTT,2VTS,2VTQ,3R8Z,1OIQ,1 

OIR,3R9D,3RJC,3R9N,2DS1 

For Linux, you may have to edit the PDB access codes to have the following screen. 

https://azevedolab.net/resources/sandres_tutorial_01/pdb_codes.csv


5.2. Tutorial 1. Dataset 12 

 

 

 
 

Figure 8. Fast Editor (Windows Version). 

 
 

Click on the Save button and the Close button. SAnDReS saved the PDB access 

codes in a file named pdb_codes.csv. If you reopen the pdb_codes.csv file, 

SAnDReS should show that you have 104 structures. To avoid repeated PDB codes, 

click on Dataset->Unify PDB Access. You get the following message: 

Done! Number of repeated PDB files: 0. 

 
 

Click on Dataset->Add->Binding Affinity Data. In the pop-up window, click on the 

Half-maximal Inhibitory Concentration (IC50) button. Then, click on the Start button. 

Once finished, you will get the following message: 

SAnDReS finished "Add Binding Affinity Data" request! 

 
 

SAnDReS added experimental binding affinity and generated a file named 

bind_IC50.csv. Click on the Done button and the Close button. 

In the following, we have the first lines of the bind_IC50.csv file. 
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Figure 9. Partial view of the bind_IC50.csv file. 

 
 

Click on Dataset->Add->Structures PDB. In the pop-up window, click on the with 

IC50 data button. Then, click on the Start button. SAnDReS will start the 

downloading of the PDB files. It may take a while since we have more than 100 

structures in this dataset. Figure 10 shows the progress bar during the downloading. 
 

 

Figure 10. Progress bar of the downloading process (Windows Version). 
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After finishing the downloading, you get the following message: 
 

SAnDReS finished the “Add Structures (PDB)” request! 

 
 

Click on the Done button and then on the Close button. 
 

SAnDReS created a pdb folder in the project directory with all downloaded structures 

and generated a plot named resol_binding.pdf. This plot is in the plots folder. 

 

 
Figure 11. Crystallographic resolution and log(IC50) for the structures of the 

CDK2_IC50 dataset. 

 

 
Click on Dataset->Add->Structures PDBQT. In the warning window, click on the Yes 

button. 
 

SAnDReS will show the following pop-up window. 
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Figure 12. PDBQT Structures Menu (Windows Version). 

 
 

Set the lowest resolution to 2.5 Å and the binding affinity to IC50. Choose Yes for the 

Unify ligands option. Unify ligands option will eliminate repeated ligands. You may 

have different PDB codes for CDK2 with the same ligand. In this case, SAnDReS 

chooses the best crystallographic resolution structure. 

Click on the Add button, then on the Start button. 

You can follow the progress as shown below. 

 
 

Figure 13. PDBQT Structures Menu with progress bar (Windows Version). 

 
 

After this task, you will get the following message: 
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SAnDReS finished the “Add Structures (PDBQT)” request! 

 
 

Click on the Done button and the Close button. 
 

Note. SAnDReS could face some problems in generating PDBQT files. In this case, 

you may delete the problematic PDB access codes from the dataset or use 

AutoDockTools4 (Morris et al., 2009) to generate the missing files. 

 

 
If you decide to do so, you should generate PDBQT files in the same directory 

created by SAnDReS. For instance, in the structure XXXX, we should keep all files in 

the C:\Users\Walter\sandres2_win\datasets\CDK2_IC50\pdbqt\XXXX directory. Since 

we have over 100 structures, we believe that is enough for all purposes (machine 

learning modeling) and we will delete any PDB code with missing PDBQT files. We 

have more than five observations (structures) for each feature used in the model 

(Gramatica, 2013). 

Click on Dataset->Check Directories for Current Dataset. Click on the Yes option. 

SAnDReS will check any missing directory in the pdbqt folder. 

You get the following message: 
 

Done! SAnDReS updated dataset! 

 
 

Click on Dataset->Check Missing PDBQT Files. SAnDReS will check any missing 

PDBQT files. 

You get the following message: 
 

Done! No missing PDBQT files in the dataset! 

 
 

Since we do not have missing PDBQT files, we do not have to update this dataset. 

Now, our dataset has now 102 structures. SAnDReS deleted the following structures: 

1G5S and 1PXK. 

We finished the Dataset part of this tutorial. 
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5.3. Tutorial 1. Docking Hub 

Here, we will carry out redocking for all crystallographic structures in the dataset. The 

goal here is to validate a docking protocol using AutoDock Vina 1.2.3. We will apply 

the best docking protocol to perform virtual screening (VS). Also, we will employ a 

SAnDReS-generated scoring function to sort VS results and predict binding for poses 

generated during the docking simulations. 

Click on Docking Hub->Enter Vina Parameters. SAnDReS will open the file 

vina_par.csv, as shown in the figure below. 
 

 

Figure 14. Fast Editor (Windows Version). 

 
 

If you are familiar with AutoDock Vina 1.2.3, you may play with the parameters. For 

this tutorial, do not change the following parameters: centering, lig_pdb, receptor, 

ligand, out, docking_engine, and score_only_vina. 

Click on the Save and Close buttons. 
 

SAnDReS 2.0 has two main approaches to running docking simulations with 

AutoDock Vina. The first, named “One-Click Docking with Vina (Centering: CM, EC, 

GC)” performs docking simulation using three different centering schemes. The first 

centering is the center of mass (CM) which is the standard procedure used by 

AutoDock Vina, the center of mass of ligand atoms. The electric center (EC) carries 

out an average of the charges found in the PDBQT files and takes it as the center for 

the ligand. SAnDReS takes the absolute values (|q|). It intends to locate the center 

close to the concentration of electric charges in the ligand structure. We define the 

coordinates of electric centers (xEC, yEC, zEC) as follows: 
 

𝑥 = 
1 
∑𝑁 (|𝑞 |𝑥 ) 

𝐸𝐶 𝑁     𝑖=1 𝑖     𝑖 

𝑦 = 
1 
∑𝑁 (|𝑞 |𝑦 ) 

𝐸𝐶 𝑁     𝑖=1 𝑖     𝑖 

𝑧 = 
1 
∑𝑁 (|𝑞 |𝑧 ) 

𝐸𝐶 𝑁     𝑖=1 𝑖    𝑖 
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Where xi, yi, zi are the atomic coordinates of each non-hydrogen atom in the ligand 

structure, N is the number of non-hydrogen atoms in the ligand, and qi is the partial 

charge of each non-hydrogen atom. The geometric center (GC) is the center where 

we consider that all non-hydrogen atoms have masses equal to 1.0. 

SAnDReS performs three docking simulations for each structure in the dataset and 

considers the best docking protocol for each entry, the one with the lowest RMSD. 

The option named “One-Click Docking with Vina (Centering: CM)” performs docking 

simulation using CM only. 

In this tutorial, we will carry out docking simulations with “One-Click Docking with 

Vina (Centering: CM, EC, GC)” to explore this new approach implemented in 

SAnDReS 2.0. 

Click on Docking Hub->One-Click Docking with Vina (Centering: CM, EC, GC)->Run 

Simulation. Click on the Yes option, then click on the Run button. You will have the 

following menu. 
 

 

Figure 15. Docking Simulations with Vina (Windows Version). 

 
 

Click on the Start button to initiate the docking simulations. 
 

This process may take a few hours, depending on your CPU. You may follow the 

evolution of the process by observing the progress bar, as shown in Figure 16. 
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Figure 16. Docking Simulations with Vina (Windows Version). 

 
 

For any unsuccessful docking simulation for a structure XXXX, you get a warning 

message as follows: 

Warning! AutoDock Vina couldn't run docking simulation for structure: XXXX! 

 
 

If the unsuccessfully docked structure is meaningful, you may try to run AutoDock 

Vina 1.2.3 outside SAnDReS. If you do that, keep the same file names and 

directories. SAnDReS will use them for further statistical analysis of the docking 

results. 

Once finished the docking simulations, you have the following message: 
 

SAnDReS finished the “One-Click Docking with Vina” request using AutoDock Vina! 

 
 

Click on the Done button and the Close button. 
 

All files generated during docking simulations are on the related folders in the pdbqt 

directory of the project directory. For instance, for the structure 1DI8, we have the 

following files shown in Figure 17. 
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Figure 17. Files found in the directory 

C:\Users\Walter\sandres2_win\datasets\CDK2_IC50\pdbqt\1DI8 (Windows Version). 

 

 
SAnDReS identifies the docking results (e.g., vina_simulation_electric.txt) and input 

files (e.g., config_electric.txt) for each centering with strings: electric, geometric, and 

mass. The file biomatrix.csv has the rotation matrix and translation vector used to 

generate the biological assembly if needed. SAnDReS creates biological units 

because you may have a protein for which the active site lays between units of the 

biological assembly e.g., human purine nucleoside phosphorylase (PNP) (de 

Azevedo et al., 2003). The asymmetric unit of human PNP is a monomer, and the 

biological assembly is a trimer. Also, the binding pocket of human PNP sits between 

the monomers (see structure 1PF7) (de Azevedo et al., 2003). 

Now, we will carry out a statistical analysis of docking results. 
 

Click on Docking Hub->One-Click Docking with Vina (Centering: CM, EC, GC)- 

>Statistical Analysis of Docking Results. Click on the Yes button. 

Once finished the statistical analysis, you have the following message: 

SAnDReS finished the “Statistical Analysis of Docking Results” request using 

AutoDock Vina! 

 

 
SAnDReS generated a file with the best docking results for each structure 

(vina_rmsd_results.csv). Figure 18 shows part of these results. 
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Figure 18. Partial view of the vina_rmsd_results.csv file. 

 
 

As you can see, the inclusion of two alternative centering schemes for docking 

simulations generated better results. We obtained most of the lowest docking RMSD 

for electric and geometric centers. The center of mass was the best center for 40 out 

of 102 structures. This simple variation of the center of docking simulations improves 

docking accuracy (DA). 

Next, we check the docking results. This part identifies unsuccessful docking 

simulations. We may delete these structures from the dataset or run docking 

simulations outside SAnDReS. 

Click on Docking Hub->Check Unsuccessful Docking Simulations. If you have 

successful docking simulations, you click on the Yes option. 

After checking docking simulations, you have the following message: 
 

Number of structures with unsuccessful docking simulations: 0 

 
 

We finished the docking hub part of this tutorial. 
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5.4. Tutorial 1. Scoring Functions 

Now, we will calculate the energy terms available in AutoDock Vina 1.2.3 for the 

crystallographic positions and poses generated during the docking simulations. To do 

that, we employ the following energy terms: Gauss 1, Gauss 2, Repulsion, 

Hydrophobic, Hydrogen, and Torsional. We will use these energy terms as features 

of our machine learning models. Also, SAnDReS can calculate some descriptors 

such as the average charge for ligands, charge for ligands, number of atoms found in 

the structure of the ligands (e.g., C, N, O). It is possible to employ these descriptors 

to generate a hybrid scoring function involving AutoDock Vina energy terms and 

selected descriptors. 

Click on Scoring Functions->Enter Vina Parameters. 
 

We have the editor with the Vina parameters. As highlighted in the previous section, 

we do not change the following parameters: centering, lig_pdb, receptor, ligand, out, 

docking_engine, and score_only_vina. 

Click on the Close button. 
 

Click on Scoring Functions->Add->Descriptors. 

We will have the following menu. 

 
 

Figure 19. Ligand Descriptors Menu (Windows Version). 

 
 

Click on the IC50 button. Click on the Yes option. 
 

After adding descriptors, you get the following message: 
 

Ligand descriptors added to bind_IC50.csv file! 

 
 

Click on the Close button. SAnDReS added new descriptors to the bind_IC50.csv 

file, as shown in Figure 20. 
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Figure 20. Partial view of the bind_IC50.csv file with recent added descriptors. 

 
 

Click on Scoring Functions->Add->Energy Terms (Vina) for Crystal Structures. 

Click on the Yes option. Click on the Run button. 

We will have the familiar menu used to run AutoDock Vina. 
 

 

Figure 21. Energy Terms for Crystallographic Structures Menu (Windows Version). 

 
 

Click on the Start button. 
 

You may follow the progression. 
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Figure 22. Energy Terms for Crystallographic Structures Menu with Anaconda 

prompt command (Windows Version). 

 

 
After finishing all calculations, you get the following message: 

 

SAnDReS finished the “Energy Terms” request using AutoDock Vina! 

 
 

Click on the Done and Close buttons. 
 

Click on Scoring Functions->Add->Energy Terms (Vina) for Poses (Centering: CM, 

EC, GC). 

Click on the Yes option. Click on the Run button. Click on the Start button. 
 

Be careful to use the same centering option used for docking simulations. Here, we 

employed the centering: CM, EC, GC. 

After ending the calculations, SAnDReS shows the following message: 
 

SAnDReS finished the "Add Energy Terms (Vina) for Poses" request! 

 
 

Click on the Done and Close buttons. Now, we check the energy calculations. 
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Click on Scoring Functions->Check Unsuccessful Scoring Function Calculations for 

Poses. 

Click on the Yes option. 
 

Then, SAnDReS shows the following message: 
 

Done! SAnDReS updated scores4poses.csv file! 

 
 

We finished this part of Tutorial 1. 
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5.5. Tutorial 1. Virtual Screening 

Here, we will use AutoDock Vina 1.2.3 to perform a docking screen of a set of 

potential ligands against our protein target, the CDK2. SAnDReS checks the docking 

results for all structures in the dataset and selects the config.txt file for the best result. 

We consider as the best docking result the one with the lowest RMSD. SAnDReS 

uses the coordinates of the receptor for which we have the lowest RMSD to run the 

virtual screening. 

To illustrate the virtual screening (VS) with SAnDReS, we will perform the simulation 

using only a small dataset of small molecules from the FDA-approved drugs. We may 

adopt this approach using the complete FDA dataset for drug repurposing purposes. 

Our goal is to show you how to use SAnDReS for virtual screenings. 

We have the file fda.mol2 with five molecules in the Ligands folder of the 

sandres2_win (or sandres2 for Linux) directory. We will employ it for training 

purposes only. We may use the complete version (fda_full.mol2) also available in the 

Ligands folder or any other dataset of small molecules in the mol2 format. Copy the 

fda.mol2 file to the project directory. Figure 23 shows the files and folders in your 

project directory. 

 

 
Figure 23. Files found in the project directory 

C:\Users\Walter\sandres2_win\datasets\CDK2_IC50\pdbqt\1DI8 (Windows Version). 

 

 
Click on Virtual Screening->Enter Virtual Screening Parameters. 

SAnDReS opens the vs_par.csv file, as shown in Figure 24. 
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Figure 24. Fast Editor (Windows Version). 

 
 

Make sure that the lig_dir is the project directory, and lig_in has fda.mol2, as shown 

above. Click on the Save button and the Close button. 

Click on Virtual Screening->Simulation->Import Ligands. 

Click on the Yes option. 

When SAnDReS finished the conversion, we have the following message: 
 

SAnDReS finished the "Virtual Screening->Import Ligands" request! 

 
 

SAnDReS converted the molecules in the fda.mol2 file to individual PDBQT files, one 

for each molecule found in the fda.mol2 file. All PDBQT files are in the VS/mols folder 

in the project directory, as shown in Figure 25. 

 

 
Figure 25. Files found in the directory 

C:\Users\Walter\sandres2_win\datasets\CDK2_IC50\pdbqt\1DI8\VS\mols (Windows 

Version). 

 

 
Now, SAnDReS tests all docking results and imports the config.txt and 

receptor.pdbqt files of the lowest docking RMSD structure. SAnDReS will copy these 

files to the VS folder of the project directory. 
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Click on Virtual Screening->Simulation->Import Receptor. 
 

Click on the Yes option. When SAnDReS finished the copying, we have the following 

message: 

SAnDReS finished the "Virtual Screening->Import Receptor" request! 

 
 

Now, in the VS folder, we have two additional files: config.txt and receptor.pdbqt. 
 

You may edit the config.txt file, clicking on Virtual Screening->Simulation->Edit 

config.txt. 

It is not necessary for this tutorial. Now, we are going to run the VS simulation. 

Click on Virtual Screening->Simulation->Run. 

Click on the Yes option. Click on the Run button. 
 

As you expect, we have a familiar docking interface, as shown in Figure 26. 
 

 

Figure 26. Docking Simulation Menu (Windows Version). 

 
 

Click on the Start button. 
 

After finishing the simulation, we have the following message: 
 

SAnDReS finished the "Virtual Screening->Run" request! 

 
 

Click on the Done button. Click on the Close button. 
 

Click on Virtual Screening->Simulation->Merge VS Results. Click on the Yes option. 

After finishing the merging, we have the following message: 

SAnDReS finished the "Virtual Screening->Merge VS Results" request! 



5.5. Tutorial 1. Virtual Screening 29 

 

Click on Virtual Screening->Simulation->Sort VS Results. 
 

Click on the Yes option. 
 

You will have the following pop-up window. 
 

 

Figure 27. Sorting VS Results Menu (Windows Version). 

 
 

Click on the Sort button. 
 

After finishing the sorting, we have the following message: 
 

SAnDReS finished the "Virtual Screening->Sort VS Results" request! 

 
 

Click on the Close button. 
 

SAnDReS generated the virtual_screening_sorted_unified.csv file with the poses 

sorted by AutoDock Vina 1.2.3 scoring function (Affinity). 

Click on Virtual Screening->Check Unsuccessful Virtual Screening Simulation. 
 

SAnDReS checks the VS results. If everything goes fine, you get the following 

message: 

Number of structures with unsuccessful virtual screening simulations: 0 

 
 

In this tutorial, we did not use the Add BindingDB option. With this option, we can 

carry out VS simulation for ligands downloaded from the BindingDB (Gilson et al., 

2016) and add the experimental data to the VS results. Then, it is possible to verify 

the correlation between predicted (e.g., Affinity) and experimental binding affinities. It 

is also possible to employ these results to generate machine learning models based 

on the VS results. It is not the goal of this tutorial. 

We finished out our VS simulations. 
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5.6. Tutorial 1. Machine Learning Box (For Modeling) 

SAnDReS 2.0 relies on Scikit-Learn 1.0.2 to generate machine learning models to 

predict binding affinity. Here, we focus on crystallographic structures to develop our 

scoring functions, not docked poses. We have two sources of experimental data, the 

crystallographic structures and the affinity data (log(IC50)). The log(IC50) is our target 

function. SAnDReS employs the crystal structures to calculate the energy terms. 

These terms are the features used in machine learning modeling. 
 

We have an arsenal of 64 regression methods (see Appendix for details) available in 

SAnDReS to generate new scoring functions. This freedom to play with the features 

and regression methods makes it possible to explore a wider region of the Scoring 

Function Space (SFS) (Bitencourt-Ferreira et al., 2021), increasing the chances of 

finding an adequate model for our protein system. Although in computational 

modeling, some argue that the data is more relevant than the machine learning 

algorithms for complex problems (Halevy et al., 2009). Several studies showed that 

variation of the machine learning algorithms generates scoring functions with 

superior predictive power compared with classical scoring functions (Xavier et al., 

2016; de Ávila et al., 2017; Pintro et al., 2017; Bitencourt-Ferreira & de Azevedo, 

2018; Levin et al., 2018; Wójcikowski et al., 2019; Ballester, 2019; da Silva et al., 

2020, Bitencourt-Ferreira et al., 2021; de Azevedo et al., 2021; de Azevedo, 2021). 

These results highlight the importance of trying different methodologies when 

studying complex systems. In SAnDReS, we adopt this idea. The idea of freedom to 

explore unexplored regions of the SFS, finding a model just right for your protein 

system. 

One key aspect of SAnDReS is the freedom of choice. You have the liberty to test 

several machine learning models, and based on the predictive performance furnished 

by SAnDReS, choose the model you find is adequate to the protein you are studying. 

To start exploring the SFS, click on Machine Learning Box->Enter Machine Learning 

Parameters. 

SAnDReS opens the ml_par.csv file. In this file, we have the definition of the 

parameters necessary to apply the regression methods available in Scikit-Learn 

1.0.2. We show part of the ml_par.csv file below. 
 
preprocessing,StandardScaler 

ml_parameters,ml.in 

scoring_function_file,scores.csv 

# Set up input parameters 

n_features,6 

features_in,Gauss 1,Gauss 2,Repulsion,Hydrophobic,Hydrogen,Torsional 

test_size_in,0.3 

seed_in,271828 

# Set up regression methods 

mlr_method,AdaBoostRegressor # AdaBoost Regression 

mlr_method,AdaBoostRegressorCV # AdaBoost Regression 

 

 
SAnDReS considers any line starting with # as a comment line. If it appears in the 

middle of a line, from that the part on is a comment. 
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The line preprocessing,StandardScaler defines the type of preprocessing. 

SAnDReS will scale the data. In the following, we have the definition of the input file 

with all specific parameters necessary to run machine learning methods available in 

Scikit-Learn 1.0.2. Please, see Appendix for details. 

The line scoring_function_file,scores.csv shows a temporary file used 

during regression analysis. You do not need to change it. The next line starts with #. 

It is a comment line. 

The line n_features,6 establishes the number of features for machine learning 

methods. Once started the machine learning, you cannot change it. We will leave as 

it is. 

The line features_in,Gauss 1,Gauss 

2,Repulsion,Hydrophobic,Hydrogen,Torsional defines the features. In 

this case, we use the energy terms available in the AutoDock Vina scoring function. If 

you want to modify it, you must do all steps from this point again. 

SAnDReS splits the data in training and test sets. The following line 

test_size_in,0.3 defines the fraction used as test set. In this tutorial, we have 

30 % of the dataset as test set. 

The line seed_in,271828 defines an integer used as a seed to generate 

pseudorandom numbers. SAnDReS employs these pseudorandom numbers to split 

the dataset into training and test sets. This definition allows us to reproduce the same 

results for the same operating system. For this tutorial, leave it as it is. The next line 

is a comment line. In the following, we have a sequence of 64 regression methods 

specified in each line, for instance, mlr_method,AdaBoostRegressor indicates 

that SAnDReS will use the AdaBoostRegressor as a method for regression. In the 

above list, we have the first two lines out of 64 representing all regression methods 

available in SAnDReS. If you want to omit any of the methods, it is necessary to add 

# as the first character in the line. You may also just delete the undesired method. 

Click on the Save button and the Close button. 
 

Click on Machine Learning Box->For Modeling->Preprocess Data. 

Click on the Yes option. 

After finishing preprocessing the data, we get the following message: 
 

SAnDReS finished the "Preprocess Data" request! 

 
 

SAnDReS generated a new file named scores4xtal.csv with scaled data. From now 

on, the machine learning modeling will use the data in this file. The use the options 

Choose PDBs for Training Set and Choose PDBs for Test Set to open a file using the 

Fast Editor. We may use these options to enter the PDB access codes you chose. 

We do not use them in this tutorial. 
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Click on Machine Learning Box->For Modeling->Automatic Generation of PDBs for 

Training and Test Sets. 

Click on the Yes option. After separating the PDB access codes in the files 

pdb_codes_test_set.csv and pdb_codes_training_set.csv, we have the following 

message: 

SAnDReS finished the "Automatic Generation of PDBs for Training and Test Sets" 

request! 

 

 
Click on Machine Learning Box->For Modeling->Generate Training and Test Sets. 

 

Click on the Yes option. Now we split the dataset. SAnDReS creates two new files, 

named: scores4xtal_test.csv and scores4xtal_training.csv. We have the following 

message after the creation of both files: 

SAnDReS finished the "Generate Training and Test Sets" request! 

 
 

Click on Machine Learning Box->For Modeling->Filter Data. 
 

Click on the Yes option three times for the following files: scores4xtal.csv, 

scores4xtal_test.csv, and scores4xtal_training.csv. In this part, SAnDReS eliminates 

any line for which we have features with nan (not a number). 

After eliminating these lines, if necessary, SAnDReS shows the following message: 
 

SAnDReS finished the "Filter Data" request! 

 
 

Now we determine the correlation between potential features and log(IC50). 

Click on Machine Learning Box->For Modeling->Statistical Analysis (Features). 

Click on the Yes option. After generating the scores4xtal_training_stats4features.csv 

file, we have the following message: 
 

SAnDReS finished the "Statistical Analysis (Features)" request! 

 
 

In this new file, we have the bivariate statistical analysis of potential features carried 

out using Scikit-Learn and SciPy. This file is sorted from the highest r2 to the lowest. 

Figure 28 shows the scores4xtal_training_stats4features.csv file. 
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Figure 28. View of the scores4xtal_training_stats4features.csv file. 

 
 

We observe the highest r2 for the following features: C, Gauss 2, Average Q, Q, 

Gauss 1, Torsional, N. 

We have a high correlation between Q and average Q. So, it is better to choose one 

of them. We keep Average Q. So, the list of features is the following: 

C,Gauss 2,Average Q,Gauss 1,Torsional,N 

 

 

Click on Machine Learning Box->Enter Machine Learning Parameters. 

We have the following view after inserting the selected features. 

 
 

Figure 29. Fast Editor (Windows Version). 
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Click on the Save button and the Close button. 
 

We should keep in mind that this selection of features does not mean that we will 

generate the best possible model. We may try different scenarios and choose the 

best-performing model. It is common to select the model that generalizes better (de 

Azevedo, 2021). It means that the model has the highest correlation between 

experimental and predicted affinity for the test set. For half of the regression methods 

available in SAnDReS, we have cross-validation (CV) approaches. 

Click on Machine Learning Box->For Modeling->Regression Methods. 

Click on the Yes option. 

SAnDReS started our exploration of the SFS. It goes into a loop, generating machine 

learning models for all methods we kept in the previously edited ml_par.csv file. For 

this tutorial, we keep them all. For each regression method, SAnDReS generates a 

model stored in the models folder of the project directory. We have these models 

saved as joblib files. These files allow us to apply previously generated models 

(.joblib file) to any dataset presented as a CSV file. Once generated a machine 

learning model (.joblib file), we may copy it, keep it on a website, or send it by email. 

Then, we can use it to predict binding affinity using as input data any CSV file that 

has the same features used to generate the machine learning. In this tutorial, we 

used the following features: C, Gauss 2, Average Q, Gauss 1, Torsional, N. 

After generating all regression models, we have the following message: 
 

SAnDReS finished the "Regression Methods" request! 

 
 

In Figure 30, we have part of the files found in the models folder. 

 

 
Figure 30. Part of the files found in the directory 

C:\Users\Walter\sandres2_win\datasets\CDK2_IC50\models (Windows Version). 
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Next, we will use these regression models (.joblib files) and apply them to 

scores4xtal_test.csv and scores4xtal_training.csv files. SAnDReS will add the 

binding affinity values predicted using all 64 regression models as additional columns 

to scores4xtal_test.csv and scores4xtal_training.csv files. We name all added 

columns as regression methods, e.g., AdaBoostRegressor for a column with binding 

affinity determined using this method. 

Click on Machine Learning Box-> For Modeling->Apply Regression Model. 

We have the following pop-up window. 

 
 

Figure 31. Joblib Model Menu (Windows Version). 

 
 

Click on the Apply button. After applying all regression models to the 

scores4xtal_training.csv file, we have the following message: 
 

SAnDReS finished the "Apply Regression Model" request! 

 
 

Click on the Close button and repeat the same procedure for the scores4xtal_test.csv 

file. In the field Regression Method of the above pop-up window, we have the 

possibility of inserting a specific method, instead of asking to add for all methods. In 

this tutorial, we keep them all. 

Click on Machine Learning Box->For Modeling->Bivariate Analysis of Regression 

Models. 

Click on the Yes option. 
 

After finishing the statistical analysis, we get the following message: 
 

SAnDReS finished the "Bivariate Analysis of Regression Models" request! 

 
 

SAnDReS performed the statistical analysis and generated the following files: 

scores4xtal_test_stats_joblib_models.csv and 

scores4xtal_training_stats_joblib_models.csv. 

Since we seek models with generalization capacity, we check the 

scores4xtal_test_stats_joblib_models.csv file. Figure 32 shows part of this file. 
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Figure 32. Partial view of the scores4xtal_test_stats_joblib_models.csv file. 

 
 

Above, we sorted the data using r2 as a sorting criterion. We see several models 

performing better than the AutoDock Vina scoring function (Affinity). We select the 

model created using the OrthogonalMatchingPursuit method since this model has 

good performance for RMSE (root-mean-square error). 

Note. SAnDReS may show nan (not a number) for statistical analysis of some 

regression methods. It happens due to errors generated in the Scikit-Learn. If you 

have only a few methods for this problem, you may ignore them. Otherwise, you may 

have to change regression parameters. Please see Appendix. 

 
 
 

Now, we have our machine learning model (OrthogonalMatchingPursuit). We will test 

it against docking results. 
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5.7. Tutorial 1. Machine Learning Box (For Docking Results) 

In this part, we will use the previously generated docking results, apply our machine 

learning models (KernelRidge) against them, and carry out the same bivariate 

statistical analysis performed for the models in the previous section. Here, SAnDReS 

will not perform machine learning regression, only apply the previously 

determined models (.joblib files) to the docking results. 

Click on Machine Learning Box->For Docking Results->Preprocess Data. 
 

Click on the Yes option. After finishing preprocessing the data, we get the following 

message: 

SAnDReS finished the "Preprocess Data" request! 

 
 

SAnDReS generated a new file named scores4poses.csv with scaled data. 
 

Click on Machine Learning Box->For Docking Results->Generate Training and Test 

Sets. 

Click on the Yes option. SAnDReS generated two new files, named: 

scores4poses_test.csv and scores4poses_training.csv. We have the following 

message after the creation of both files: 

SAnDReS finished the "Generate Training and Test Sets" request! 

 
 

Click on Machine Learning Box->For Docking Results ->Filter Data. 
 

Click on the Yes option three times for the following files: scores4poses.csv, 

scores4poses_test.csv, and scores4poses_training.csv. Once finished, we have the 

following message: 

SAnDReS finished the "Filter Data" request! 

 
 

Click on Machine Learning Box->For Docking Results->Apply Regression Model. 
 

As we saw in the previous section, we have a pop-up window. Initially, we apply the 

regression models to the scores4poses.csv file. We click on the Apply button and 

then on the Close button. Repeat the same procedure for the following files: 

scores4poses_training.csv and scores4poses_test.csv. Different from the previous 

section, we applied the models to three files. After the inclusion of all regression 

models, we have the following message: 

SAnDReS finished the "Apply Regression Model Docking Results" request! 
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Click on Machine Learning Box->For Docking Results->Bivariate Analysis of 

Regression Models. 

Click on the Yes option. After finishing the statistical analysis, we get the following 

message: 

SAnDReS finished the "Bivariate Analysis of Regression Models Applied Docking 

Results" request! 

 

 
Figure 33 shows a partial view of the scores4poses_test_stats_joblib_models.csv 

file. 
 

Figure 33. Partial view of the scores4poses_test_stats_joblib_models.csv file. 

 
 

As we can see, our machine learning model (OrthogonalMatchingPursuit) performs 

better than the Affinity function taking docking accuracy (DA1) (Xavier et al., 2016) as 

a sorting criterion. The performance is also better for r2 and RMSE. Amongst all 

these metrics, we may say that the most demanding for a machine learning model 

trained against binding affinity data and crystal structures are the DAs, and our model 

has an improvement of almost 13.33 % for DA1. Additionally, we may take a machine 

learning model to predict binding affinity and a different model to sort docking poses. 

In summary, the overall performance of the OrthogonalMatchingPursuit model is 

better for sorting poses and predicting the binding affinity. 

We finished our application of machine learning models to docking results. 
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5.8. Tutorial 1. Machine Learning Box (For Virtual Screening Results) 

In this part, we will apply the OrthogonalMatchingPursuit model to the results of our 

VS simulation. We will employ one regression model only. Our goal is to use a 

machine learning model to sort VS poses, selecting the most promising ones (lowest 

score). Remember, we have only five ligands in the dataset used for VS. We intend 

only to show you how to apply our approach to this problem. For real VS projects, we 

need larger datasets, but the procedure is the same. 

Click on Machine Learning Box->For Virtual Screening Results->Preprocess Data. 

Click on the Yes option. 

After finishing preprocessing the data, we get the following message: 
 

SAnDReS finished the "Preprocess Data for Virtual Screening Results" request! 

 
 

Click on Machine Learning Box->For Virtual Screening Results->Apply Regression 

Model. 

In the new pop-up window, we change the regression method to 

OrthogonalMatchingPursuit. We have the screen shown below. 
 

Figure 34. Joblib Model Menu (Windows Version). 

 
 

Click on the Apply button and the Yes option. You get the following message: 
 

SAnDReS finished the "Apply Regression Model Virtual Screening Results" request! 

 
 

Click on the Close button. 
 

Click on Machine Learning Box->For Virtual Screening Results->Sort VS Results. 
 

Click on the Yes option then we get a new pop-up window. In the Sorting Criterion 

field, type OrthogonalMatchingPursuit 

We have the following window. 
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Figure 35. Sorting VS Results (Windows Version). 

 
 

Click on the Sort button. 
 

You get the following message: 
 

Finished sorting VS results! 

 
 

Click on the Close button. SAnDReS added the OrthogonalMatchingPursuit predicted 

values to the last column. Figure 36 shows part of the 

virtual_screening_sorted_unified.csv file. 
 

 
Figure 36. Partial view of the virtual_screening_sorted_unified.csv file. 

 
 

In the above figure, we see in the last column the predicted binding affinity generated 

with OrthogonalMatchingPursuit method. 

We finished the application of the machine learning model to VS results. 
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5.9. Tutorial 1. Statistical Analysis 

In the last part of tutorial 1, we will perform some statistical analysis and generate 

plots. SAnDReS keeps all graphic files in the plots folder of the project directory. To 

start, we will create a scatter plot. 

Click on Statistical Analysis->Scatter Plot->Set up Parameters. 
 

We have a new pop-up window. Add OrthogonalMatchingPursuit to the Y-axis Label 

field. We have the following window. 
 

 

Figure 37. Matplotlib: Visualization with Python Menu (Windows Version). 

 
 

Click on the Apply button. Click on the Close button. 
 

To generate the plot, click on Statistical Analysis->Scatter Plot->Generate. 

We have the following pop-up window. 

 
 

Figure 38. Matplotlib: Visualization with Python Menu (Windows Version). 

 
 

Click on the 2D-View button. Click on the Close button. 

SAnDReS generated the following plot. 
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Figure 39. Scatter plot of OrthogonalMatchingPursuit vs log(IC50) for 

scores4xtal_test.csv file (Windows Version). 

 

 
Click on the Close button. To assess the intermolecular contacts, click on Statistical 

Analysis->2D Plot Intermolecular Interactions. 

We have the following pop-up window. 
 

 

Figure 40. Matplotlib: Visualization with Python Menu (Windows Version). 

 
 

Click on the Plot button. Click on the Yes button. It may take a few minutes to count 

all contacts. After finishing, we get the following message: 

SAnDReS finished the “Add 2D Plot” request! 
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Click on the Close button. SAnDReS generated the following plots. 

 

 

Figure 41. Intermolecular contacts taking all atoms in the protein (A), main-chain 

atoms (B), and side-chain atoms (C) (Windows Version). 
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To have a 3D-view of the intermolecular contacts, click on Statistical Analysis->3D 

Plot Intermolecular Interactions. 

We have the following pop-up window. 
 

 

Figure 42. Matplotlib mplot3d Toolkit (Windows Version). 

 
 

Click on the 3D-View button. Click on the Yes button. 
 

Now, we have an interactive 3D-view of the intermolecular contacts for all the 

structures in the dataset. You may left-click on the figure to rotate it. 
 

Figure 43. Interactive 3D-view of the intermolecular contacts (Windows Version). 

 
 

To generate a plot, close the interactive window. Click on the Plot button and the Yes 

option. SAnDReS will generate the bar_plot_3d.pdf file in the plots directory. You get 

the following message: 

SAnDReS finished the “Add 3D Plot” request! 
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Click on the Close button. We finished the statistical analysis. Now, let’s save our 

results as a zipped folder. Click on Setup->Project Directory->Backup Current 

Project. 

Click on the Yes option. It may take a few minutes. After backing up the current 

project directory, you get the following message: 

Successfully created a backup of the directory 

C:/Users/Walter/sandres2_win/datasets/CDK2_IC50/ 

 

 
You may delete or unzip this zipped folder using additional options in the Setup menu 

shown in Figure 44. 
 

 

Figure 44. Setup menu (Windows Version). 

 
 

To finish this session, click on Setup->Exit. 
 

Click on the Yes option. We finished Tutorial 1. 
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6. Tutorial 2. Molegro Virtual Docker Data 

Here, we will explore some new tools unseen in Tutorial 1. We will use virtual 

screening (VS) results generated with Molegro Virtual Docker (MVD) (Thomsen & 

Christensen, 2006) for a dataset with CDK2 inhibitors downloaded from the 

BindingDB (Gilson et al., 2016). We employed the PDB 2C5N without waters and 

ligands as our protein target in the VS simulation with the MVD. Our goal is to 

generate machine learning models with external VS results generated with MVD. We 

will not carry out docking simulations and calculations of using AutoDock Vina 

through the SAnDReS interface. We will convert the MVD data to SAnDReS format 

and use it to generate machine learning models. To run this tutorial, you will need the 

following files: cdk2ki.sdf, cdk2ki.tsf, and vs2.csv. We downloaded the first two files 

directly from the BindingDB on January 12, 2022. We carried out a search on the 

BindingDB for inhibitors of CDK2 with Ki data. We found a total of 131 ligands, but we 

have repeated entries. SAnDReS will filter this dataset to have unique ligands in our 

dataset. The cdk2ki.tsf file has the binding affinity data. SAnDReS uses this 

information to generate the affinity_BindingDB_Ki.csv file. This internal file furnishes 

binding data to generate the bind_Ki.csv file. We have the VS results generated with 

MVD for unique ligands in the vs2.csv file. You find all necessary files to run this 

tutorial in the Ligands folder of the sandres2_win directory (sandres2 for Linux). 
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6.1. Tutorial 2. Setup 

To learn how to start SAnDReS see Tutorial 1. If you have already downloaded the 

ligand databases, you do not have to do that again. We must define a project 

directory different from the one used in Tutorial 1. Click on Setup->Parameters- 

>Enter Project. 
 

SAnDReS opens the strdir.in file. In the new pop-up window, add the following 

project directory: C:/Users/Walter/sandres2_win/datasets/CDK2_MVD/ 

We have the following view. 
 

 

Figure 45. Fast Editor (Windows Version). 

 
 

Click on the Save button and the Close button. 
 

Click on Setup->Project Directory->Make a New Project. 
 

Click on the Yes option. 
 

SAnDReS creates a new directory and shows the following message: 
 

Successfully created the directory 

C:/Users/Walter/sandres2_win/datasets/CDK2_MVD/ 

 

 
It is necessary to copy to the project directory the following files: cdk2ki.sdf, 

cdk2ki.tsf, and vs2.csv. These files are in the Ligands folder. Now, we filter the 

ligands in the cdk2ki.sdf file and read binding data in the cdk2ki.tsv file. 

Click on Setup-BindingDB Data. 
 

Click on the Yes option. 
 

SAnDReS shows the following pop-up window. 
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Figure 46. BindingDB Menu (Windows Version). 

 
 

Both files (cdk2ki.sdf and cdk2ki.tsv) should be in the project directory. Click on the 

Prepare button. 
 

SAnDReS will read binding affinity data and filter ligands then we get the following 

message: 

Done! SAnDReS prepared BindingDB data for machine learning modeling! 

 
 

Click on the Close button. SAnDReS generated two new files: 

affinity_BindingDB_Ki.csv and cdk2ki_out.sdf. The first file has the ligand IDs and 

binding affinity data; the last one has the atomic coordinates for all ligands after 

deleting the repeated ones. 

We finished this part of Tutorial 2. 
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6.2. Tutorial 2. Machine Learning Box 

We will use the VS results to generate a machine learning model. This information is 

in the vs2.csv file generated with MVD. 

Click on Machine Learning Box->For Modeling Using Molegro Results->Set up 

Molegro Parameters. 

SAnDReS opens the molegro_par.csv file. In this file, we have energy terms 

(features_in). Also, we have the scoring function used by MVD in the VS simulation. 

In this tutorial is the PlantsScore. 

For this tutorial, leave the default values. Click on the Close button. 
 

Click on Machine Learning Box->For Modeling Using Molegro Results->Convert VS 

Data. 

Click on the Yes option. 
 

SAnDReS shows the following pop-up window. 
 

 

Figure 47. Menu to convert from MVD to SAnDReS format (Windows Version). 

 
 

Click on the Convert button. 
 

After converting, SAnDReS show the following message: 
 

Done! Molegro data converted to SAnDReS format! 

 
 

Click on the Close button. 
 

SAnDReS generated bind_Ki.csv file. 
 

Click on Machine Learning Box->Enter Machine Learning Parameters. 
 

You should have MVD energy terms in the features_in, as shown in the following 

figure. 
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Figure 48. Fast Editor (Windows Version). 

 
 

Click on the Save button and the Close button. 
 

If you look at the Machine Learning Box, we will see that the sequence of commands 

is the same used in Tutorial 1 (Section 5.6). Please, follow the same steps to 

generate a machine learning model with MVD data. 

Click on Machine Learning Box->For Modeling Using Molegro Results->Preprocess. 
 

Click on Machine Learning Box->For Modeling Using Molegro Results->Automatic 

Generation of PDBs for Training and Test Sets. 

Click on Machine Learning Box->For Modeling Using Molegro Results->Generate 

Training and Test Sets. 

Click on Machine Learning Box->For Modeling Using Molegro Results->Filter Data. 
 

Click on Machine Learning Box->For Modeling Using Molegro Results->Statistical 

Analysis (Features). 

Click on Machine Learning Box->For Modeling Using Molegro Results->Regression 

Methods. 

Click on Machine Learning Box->For Modeling Using Molegro Results->Apply 

Regression Model. 

Click on Machine Learning Box->For Modeling Using Molegro Results->Bivariate 

Analysis of Regression Models. 

In the end, you will have new machine learning models based on the MVD energy 

terms. The following figure shows the scores4xtal_test_stats_joblib_models.csv file 

sorted by rho. The best model has rho = 0.6557 for ExtraTreesRegressorCV method. 

The correlation for the MVD scoring function (PlantsScore) is -0.297656. As we can 

see, our machine learning models present better overall predictive performance. 
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Figure 49. Partial view of the scores4xtal_test_stats_joblib_models.csv file. 

 
 

Note. SAnDReS may show nan (not a number) for statistical analysis of some 

regression methods. It happens due to errors generated in the Scikit-Learn. If you 

have only a few methods for this problem, you may ignore them. Otherwise, you may 

have to change regression parameters. Please see Appendix. 

 
 
 

We finished the development of machine learning models of this tutorial. 
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6.3. Tutorial 2. Statistical Analysis 

We may now generate a scatter plot for our best machine learning model. 

Click on Statistical Analysis->Scatter Plot->Set up Parameters. 

In the new pop-up window, insert in the field Y-axis Label the best model: 
ExtraTreesRegressorCV 

 

We have the following view. 
 

 

Figure 50. Matplotlib: Visualization with Python Menu (Windows Version). 

 
 

Click on the Apply button. 
 

SAnDReS generate the following message: 
 

The plotting information was successfully updated! 

 
 

Click on the Close button. 
 

Click on Statistical Analysis->Scatter Plot->Generate. 

We have the following pop-up window. 

 
 

Figure 51. Matplotlib: Visualization with Python Menu (Windows Version). 

 
 

Click on the 2D-View button. SAnDReS generates the following plot. 
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Figure 52. Scatter plot of ExtraTreesRegressorCV vs log(Ki) for scores4xtal_test.csv 

file (Windows Version). 

 

 
To finish Tutorial 2, we save our results as a zipped folder. Click on Setup->Project 

Directory->Backup Current Project. 

Click on the Yes option. After finishing the backup, SAnDReS shows the following 

message: 

Successfully created a backup of the directory 

C:/Users/Walter/sandres2_win/datasets/CDK2_MVD/ 

 

 
Click on Setup->Exit. 

Choose the Yes option. 

We finished Tutorial 2. 
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7. Tutorial 3. Docking of One Structure 

Here, we will show how to use SAnDReS to run docking simulations for one 

crystallographic structure (redocking). We developed SAnDReS to explore the 

Scoring Function Space, which demands as many structures as possible. For 

instance, in Tutorial 1, we worked with 102 crystal structures. Nevertheless, we can 

enjoy the SAnDReS integration and run docking simulations for one PDB. 

We will perform docking simulations for the human purine nucleoside phosphorylase 

(PNP) complexed with immucillin-H (PDB access code: 1PF7) (de Azevedo et al., 

2003). It is possible to highlight one additional aspect of SAnDReS here. For PNP, 

the asymmetric unit is a monomer, and the biological unit is a trimer with the inhibitor 

(immucillin-H) bound at the interface between monomers (de Azevedo et al., 2003). 

So if you download the PDB without investigating these differences, you might end 

up carrying out docking simulations for a structure not adequate for analysis of 

intermolecular interactions (the monomer structure). SAnDReS automatically carries 

out this analysis and generates the biological unit if necessary. Docking simulations 

focused on the PNP monomer would miss important intermolecular contacts found in 

the trimeric structure. 
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7.1. Tutorial 3. Setup 

We consider that you have already installed SAnDReS and downloaded the ligand 

databases. We show the details about starting SAnDReS and downloading ligand 

databases in Tutorial 1. 

Now, we must define a new project directory. 

Click on Setup->Project Directory->Enter Project. 

SAnDReS opened the strdir.in file. Add the following line to this file. 

STRDIR,C:/Users/Walter/sandres2_win/datasets/HsPNP/ 

The following figure shows the editing. 

 
 

Figure 53. Fast Editor (Windows Version). 

 
 

Click on the Save button and the Close button. 
 

Click on Setup->Project Directory->Make a New Project. 
 

Click on the Yes option. SAnDReS generates the new folder and shows the following 

message: 

Successfully created the directory C:/Users/Walter/sandres2_win/datasets/HsPNP/ 

 
 

We finished the Setup part of this tutorial. 
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7.2. Tutorial 3. Dataset 

Now, we will add the PDB access code. 

Click on Dataset->Enter PDB Access Codes. 

In the new pop-up window, we add the PDB access code: 1PF7 
 

 

Figure 54. Fast Editor (Windows Version). 

 
 

Click on the Save button and the Close button. 

Click on Dataset->Add->Binding Affinity Data. 

Click on the Ki button and the Start button. After finishing, we have the following 

message: 

SAnDReS finished the "Add Binding Affinity Data" request! 

 
 

Click on the Done button and the Close button. 

Click on Dataset->Add-Structures (PDB). 

Click on the with Ki data button and the Start button. 
 

SAnDReS will download the PDB file. After downloading it, we have the following 

message: 

SAnDReS finished the "Add Structures (PDB)" request! 
 

Click on the Done button and the Close button. 

Click on Dataset->Add-Structures (PDBQT). 

Click on the Yes option. 
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We have the following pop-up window. 
 

 

Figure 55. Menu to generate PDBQT structures (Windows Version). 

 
 

Click on the Add button and the Start button. 
 

SAnDReS generates a PDBQT file and shows the following message: 
 

SAnDReS finished the "Add Structures (PDBQT)" request! 

 
 

Click on the Done button and the Close button. 
 

Click on Dataset->Check Directories for Current Dataset. 

We get the following message: 

Done! There are no missing PDBQT directories! 

 
 

Click on Dataset->Check Missing PDBQT files. 

We have the following message: 

Done! No missing PDBQT files in the dataset! 

 
 

It is not necessary to update the dataset. We finished the dataset part of this tutorial. 
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7.3. Tutorial 3. Docking Hub 

In this part, we perform docking simulations. 

Click on Docking Hub->Enter Vina Parameters. 

We may edit the vina_par.csv. For this tutorial, leave it as it is. Click on the Close 

button. 
 

Click on Docking Hub->One-Click Docking Simulation with Vina (Centering: CM, EC, 

GC)->Run Simulation. 

Click on the Yes option and the Run button. Click on the Start button. 

After finishing docking simulations, we have the following message: 

SAnDReS finished the "One Click Docking with Vina" request using AutoDock Vina! 

 
 

Click on the Done button and the Close button. 
 

Note. We should not perform a statistical analysis of the docking results since we 

have only one structure. This statistical analysis determines docking accuracy for an 

ensemble of structures. 

 

 
Your results are on C:\Users\Walter\sandres2_win\datasets\HsPNP\pdbqt\1PF7 

folder as shown in Figure 56. 
 

 
Figure 56. Files found in the directory 

C:\Users\Walter\sandres2_win\datasets\HsPNP\pdbqt\1PF7 (Windows Version). 



7.3. Tutorial 3. Docking Hub 59 

 

SAnDReS wrote the RMSD values in the following files: vina_results_electric.csv, 

vina_results_geometric.csv, and vina_results_electric.csv. 

The geometric centering generated the lowest RMSD (0.8129 Å) against 0.879 Å 

(electric) and 3.096 Å (mass). 

Now, we save our results as a zipped folder. Click on Setup->Project Directory- 

>Backup Current Project. 
 

Click on the Yes option. After finishing the backup of the current project, SAnDReS 

shows the following message: 

Successfully created a backup of the directory 

C:/Users/Walter/sandres2_win/datasets/HsPNP/ 

 

 
Click on Setup->Exit. 

Click on the Yes option. 

We finished this tutorial. 
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8. Tutorial 4. Cyclin-Dependent Kinase 2 with Ki Data 

In Tutorial 1, we generated a machine learning model to predict log(IC50). Here, we 

focus on CDK2 with inhibition constant (Ki) data. Our goal is to develop a machine 

learning model to predict log(Ki). 
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8.1. Tutorial 4. Setup 

We begin this part considering that you started SAnDReS and downloaded the ligand 

databases. Any doubts related to these tasks, please see Tutorial 1. 

Let’s define the project directory. Click on Setup->Project Directory->Enter Project. 

In the editor, enter the following string: 

C:/Users/Walter/sandres2_win/datasets/CDK2_Ki/ 

 

Click on the Save button and the Close button. 
 

Click on Setup->Project Directory->Make a New Project. 
 

Click on the Yes option. SAnDReS created a new project directory. We have the 

following message: 

Successfully created the directory C:/Users/Walter/sandres2_win/datasets/CDK2_Ki/ 

 
 

Now, on the main menu, click on the RCSB button. SAnDReS shows the following 

pop-up window. 
 

 

Figure 57. RCSB Menu (Windows Version). 

 
 

In this menu, we insert 2A4L (CDK2 in complex with roscovitine) (de Azevedo et al., 

1997). Click on the Sequence button to start Google Chrome at the PDB site with the 

sequence for the structure 2A4L. If you have an error message here, please check 

the installation of Google Chrome on your computer. If everything is fine, you can Ctrl 

C the amino acid sequence of the CDK2 structure. Back to the RCSB menu, click on 

the RCSB Advanced Search button. SAnDReS will open the PDB advanced search 

tool with Google Chrome. Set up the parameters as shown in the following figure. Do 

not forget to Ctrl C the CDK2 sequence to the field sequence. 
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Figure 58. Advanced Search Menu (Windows Version). 

 
 

Click on the magnifying glass symbol on the right and click on the OK option. Click on 

the download icon on the bottom right and Ctrl C the PDB access codes. You may 

download the pdb_codes.csv file by clicking here. You have to save this file in the 

project directory. We have the following PDB access codes for this tutorial: 

1JSV,1H1S,4ACM,1PF8,1H1P,1PYE,2FVD,2EXM,2CLX,2XMY,2C6O,1E1V,4B 

CM,4BCK,4BCP,1E1X,1PXM,1PXN,1PXO,4BCO,1PXP,4BCN,4EOS,4EOR,4EOP 

,4EOI,4EON,4EOL,4EOK 

 

 

Close Google Chrome. Click on the Close button of the RCSB menu. 

We finished this part of Tutorial 4. 

https://azevedolab.net/resources/sandres_tutorial_04/pdb_codes.csv
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8.2. Tutorial 4. Dataset 

Click on Edit->Parameters->Project Summary. 

In the editor, add the following sentence: 

CDK2 with Ki data 

 

 

Click on the Save button and the Close button. 

Click on Dataset->Enter PDB Access Codes. 

Ctrl C the PDB access codes. Click on the Save button and the Close button. 

Click on Dataset->Unify PDB Access Codes. 

SAnDReS will show the following message: 
 

Done! Number of repeated PDB files: 0. 

 
 

Click on Dataset->Add->Binding Affinity Data. 
 

On the new pop-up window, click on the Ki button and the Start button. 

After finishing adding Ki data, SAnDReS shows the following message: 

SAnDReS finished the "Add Binding Affinity Data" request! 

 

Click on the Done button and the Close button. 

Click on Dataset->Add->Structures (PDB). 

On the new pop-up window, click on the Ki button and the Start button. 

After completing the downloading, we get the following message: 

SAnDReS finished the "Add Structures (PDB)" request! 

 

Click on the Done button and the Close button. 

Click on Dataset->Add->Structures (PDBQT). 

Click on the Yes option. Click on the Add button and the Start button. 

Once finished, we have the following message: 

SAnDReS finished the "Add Structures (PDBQT)" request! 
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Click on the Done button and the Close button. 

 
 

Click on Dataset->Check Directories for Current Dataset. 

SAnDReS shows the following message: 

Done! There are no missing PDBQT directories! 

 
 

Click on Dataset->Check Missing PDBQT files. 

We get the following message: 

Done! No missing PDBQT files in the dataset! 

 
 

We do not need to update the dataset. We finished the dataset part of this tutorial. 
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8.3. Tutorial 4. Docking Hub 

Now, we perform docking simulations. 
 

Click on Docking Hub->One-Click Docking with Vina (Centering: CM, EC, GC)->Run 

Simulation. 

Follow the same steps shown in Tutorial 1 (Section 5.3). Once finished, we have the 

best RMSD for each structure in the vina_rmsd_results.csv file. SAnDReS deleted 

one PDB from the dataset due to an unsuccessful docking simulation (PDB access 

code: 4BCP). Now, our dataset has 28 structures. Below, we have part of the 

summary of the docking results (docking_summary.txt). 

Docking accuracies 
DA1 = 0.286 
DA2 = 0.295 
Docking RMSD 
Mean RMSD (A) = 4.666 
Maximum RMSD (A) = 8.366 
Minimum RMSD (A) = 1.034 
No docking results for the following PDB(s): ['4BCP'] 

We finished this part of Tutorial 4. 
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8.4. Tutorial 4. Scoring Functions 

Now we calculate the energy terms for the crystal structures and docked poses. We 

follow the same procedure described in Tutorial 1 (Section 5.4), only keeping in mind 

that the binding affinity for this tutorial is Ki. Here, we generate the scores4poses.csv 

file with the energy terms for all poses. We have the energy terms added to the 

bind_Ki.csv file for the crystal structures. 

We finished the calculation of the energy terms. We will use this data to generate 

machine learning models. 
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8.5. Tutorial 4. Machine Learning Box 

Here, we generate machine learning models based on the energy terms calculated 

for the crystal structures. Since we have only 28 PDBs in the dataset, we need extra 

care in the machine learning modeling. Some authors define five as the minimum 

number of observations for each feature in the modeling (Gramatica, 2013). 

Considering that we take 70 % of the dataset as the training set, we have 20 

structures (observations). But for cross-validation, we take 80 % of the training set. 

We ended up with 16 entries. So, we can barely build a model with three features. 

We repeat the steps described in Tutorial 1 for the machine learning part (Section 

5.6). We take the following features: O, Torsional, Gauss 1, Gauss 2. 

After finishing the generation of the machine learning models, we may check the 

predictive performance by analyzing the scores4xtal_test_stats_joblib_models.csv 

file. Figure 59 shows part of the results. 
 

 

Figure 59. Partial view of the scores4xtal_test_stats_joblib_models.csv file. 

 
 

Here, our machine learning models generalize better than the AutoDock Vina scoring 

function (Affinity), which has an r2 = 0.00909986. Figure 60 shows the scattering plot 

of the GaussianProcessRegressorCV model against the experimental log(Ki) for the 

test set (r2 = 0.1761). To check how to create the scatter plots, see Tutorial 1 

(Section 5.9). 
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Figure 60. Scatter plot of GaussianProcessRegressorCV vs log(Ki) for 

scores4xtal_test.csv file (Windows Version). 

 

 
We may apply our regression model to sort docking results, as shown in Tutorial 1 

(Section 5.7). We will not carry out this task here. 

Finally, we will save these results as a zipped folder. Click on Setup->Project 

Directory->Backup Current Project. 

Click on the Yes option. After finishing the backup of the current project, SAnDReS 

shows the following message: 

Successfully created a backup of the directory 

C:/Users/Walter/sandres2_win/datasets/CDK2_Ki/ 

 

 
Click on Setup->Exit. 

Click on the Yes option. 

We finished Tutorial 4. Any question related to this tutorial, or any other material 

related to SAnDReS feel free to email us mailto:sandres@azevedolab.net. 

mailto:sandres@azevedolab.net
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9. Scoring Function Space 

We envisage protein-ligand interaction as a result of the relation between the protein 

space (Smith, 1970) and the chemical space (Bohacek et al., 1996), and we propose 

to approach these sets as a unique complex system, where the application of 

computational methodologies could contribute to understand the structural basis for 

the specificity of ligands for proteins. Such approaches have the potential to create 

novel scoring functions to predict binding affinity with superior predictive power when 

compared with standard methodologies. We propose to use the abstraction of a 

mathematical space composed of infinite computational models to predict ligand- 

binding affinity, named here as scoring function space (Heck et al., 2017; Bitencourt- 

Ferreira & de Azevedo Jr., 2019). 

Using supervised machine learning techniques, we can explore this scoring function 

space to build a computational model targeted to a specific biological system. 

SAnDReS explores the SFS using 64 machine learning methods, as highlighted in 

Tutorials 1, 2, and 4. 
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10. FAQ. Frequently Asked Questions 

1) Why does SAnDReS only use crystallographic structures in the ligand databases? 
 

Answer. A recent review (Veit-Acosta & de Azevedo, 2021) showed that the X-ray 

diffraction crystallography contributed to over 99 % of the protein structures for which 

Ki, Kd, and IC50 data is available. That is the main reason SAnDReS focused 

exclusively on crystallographic structures. 

 

 
2) Can I use SAnDReS to analyze RNA/DNA datasets? 

 

Answer. No, the current version of SAnDReS does not handle nucleic acids. 

 
 

3) Can I include peptides (or polysaccharides) in the ligand database? 
 

Answer. SAnDReS does not handle peptides (or polysaccharides) as ligands. The 

major problem is how SAnDReS identifies active ligands (with binding data), with one 

set of three characters (e.g., RRC) and only one number for each ligand. If you have 

a peptide (or polysaccharide) satisfying these limitations, it should work. Otherwise, 

the answer is no. 

 

 
4) Can I use AutoDock4 or Vinardo scoring functions in SAnDReS? 

 

Answer. No. AutoDock Vina 1.2.3 handles these scoring functions, but the current 

version of SAnDReS considers only the AutoDock Vina energy terms (Gauss 1, 

Gauss 2, Repulsion, Hydrophobic, Hydrogen, and Torsional). Considering the built-in 

descriptors and AutoDock Vina energy terms combined with 64 regression methods, 

we have a wide range of possibilities of generating scoring functions with SAnDReS. 

Nevertheless, it is always possible to add external energy terms editing the scoring 

function files. 

 

 
5) I generated PDBQT files for my dataset using Dataset->Add->Structures (PDBQT) 

using AutoDockTools4. I got several messages reporting a not successful generation 

of PDBQT files. Is that a bug? 

Answer. No. SAnDReS integrates several packages such as MGLTools, AutoDock 

Vina, Scikit-Learn, and with such huge integration, we lost some specificity of each of 

the packages that SAnDReS handles. Most notably for MGLTools 1.5.7 

(AutoDockTools). It is always possible to generate the PDBQT files outside 

SAnDReS. If you keep the same file names and directories, SAnDReS will recognize 

them all. 

 

 
6) Structures are missing in the ligand databases. Can I add them? 
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Answer: Sure. We intend to update the ligand databases every year. And I will be 

glad to receive an email with any addition you have 

(mailto:sandres@azevedolab.net). You may edit the CSV files (bind_IC50.csv, 

bind_Kd.csv, and bind_Ki.csv) on the sandres2_win\misc\data directory. It is also 

necessary to add ligand PDBQT files in the sandres2_win\misc\data\pdbqt directory. 

Alternatively, you may use a built-in function of SAnDReS to add ligands to the 

databases. It is necessary to have a CSV file with the data you want to add. You may 

find a template (add_ligand_data.csv) in the Ligands folder. You also need the 

structures in the pdbqt folder. For each structure in the CSV file, you need a lig.pdbqt 

file in the pdbqt folder. To add the new ligand data, do as follows: 

a) Click on Edit->Parameters->Ligands to Add. 
 

b) In the new pop-up window, enter the type of binding affinity to add (bind_in), the 

ligand directory (ligand_dir), and the CSV file (ligand_data). Click on the Save 

button and Close button. 

c) Click on Edit->Manually Add Data to Ligand Databases. Click on the Yes option. If 

everything goes fine, you will get the following message: Done! Successfully updated 

Ligand Database! 

For the template (add_ligand_data.csv), we added data for structure 4I3K. You may 

check the bind_Ki.csv file of the Ligand Database. Click on Edit->Binding Affinity 

Ligand Data (Ki). You will see in the first line after the header: 4I3K,1BX,A, 

505,3.31,1.0,2.8e-07,-6.552841968657781,6.552841968657781 

 

 
7) My machine learning model does not generalize well. How can I improve it? 

 

Answer. There is no easy answer to this question. The main strength of SAnDReS is 

the freedom to generate a machine learning model adequate to your protein system. 

If the model is not what you expected, try to play with the features. Try alternative 

sets of features that might generate a model that generalizes better. Keep trying. 

With SAnDReS, you have the liberty to explore different regions of the SFS. 

 
 

8) Can I use SAnDReS to generate machine learning models using energy terms or 

descriptors from other sources? 

Answer. Certainly, yes. Please see Tutorial 2. If you have your data as a CSV file, 

you can easily deceive SAnDReS, and it will take your dataset to generate machine 

learning models. 

 

 
9) How do I cite SAnDReS?  

 

Answer. Thank you very much for your question. SAnDReS 2.0.0 became 

operational on January 12, 2022. And we are about to submit it (March 17, 2022). 

mailto:sandres@azevedolab.net
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If you are in a hurry, please cite the paper describing SAnDReS 1.0. It is the 

following: 

Xavier MM, Heck GS, Avila MB, Levin NMB, Pintro VO, Carvalho NL, Azevedo WF. 

SAnDReS a Computational Tool for Statistical Analysis of Docking Results and 

Development of Scoring Functions. Comb Chem High Throughput Screen. 

2016;19(10):801-812. doi: 10.2174/1386207319666160927111347. PMID: 

27686428. 

 
 

10) Can I use part of the SAnDReS code in my program? 
 

Answer. Yes. But, you need to give credit to those who developed SAnDReS. See 

question 9. SAnDReS is free software (GNU General Public License v3.0). 

 

 
11) Can I run SAnDReS on a Mac OS? 

 

Answer. There are some issues related to the Mac OS. The most critical one is 

related to MGLTools. MGLTools is NOT working under the Catalina OS. Please see 

the following note: https://ccsb.scripps.edu/mgltools/. 

If you substitute the executables in misc\linux_third_party_software\vina folder for 

Mac ones, and follow the same steps described for the Linux installation, I expect 

that SAnDReS would run on some of the Mac OS. But there is a problem with 

Catalina OS. 

 

 
12) Can I use SAnDReS to run docking simulation for one structure? 

 

Answer. Yes. See Tutorial 3. But we did not develop SAnDReS for this. Our main 

goal is to provide a free software to explore the Scoring Function Space. In doing so, 

SAnDReS generates an adequate scoring function to predict binding and ranking 

poses. There is one limitation to running SAnDReS for one structure. This structure 

needs to have experimental binding affinity in the ligand databases. You may edit the 

ligand database yourself and add any missing ligand data. 

 

 
13) Can I export a machine learning model to another project directory? 

 

Answer. Yes. It is necessary to copy the joblib file to the models folder in your project 

directory. For instance, in Tutorial 1, we selected the OrthogonalMatchingPursuit 

model. We can find it in the 

C:\Users\Walter\sandres2_win\datasets\CDK2_IC50\models folder. Just copy the 

model_OrthogonalMatchingPursuit.joblib file to the new project directory (in the 

models folder). To use the model, follow Tutorial 1 (Section 5.8). 

https://ccsb.scripps.edu/mgltools/
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14) How can I make available a machine learning model generated with SAnDReS? 
 

Answer. One way to do that is to make the joblib file available on GitHub. If you want 

to cite it in a paper, include the link to the model in your manuscript. If you are not 

familiar with GitHub or did not want to keep a link for it, we would be glad to make 

your model available in the SAnDReS GitHub 

(https://github.com/azevedolab/sandres). Just send me an email 

mailto:sandres@azevedolab.net that I upload your model. 

We are working on the development of a database of SAnDReS models. Once we 

have this database, users may submit their models. We will include in future versions 

of SAnDReS a tool to download previously generated machine learning models. 

 

 
15) Can I use another version of Scikit-Learn? 

 

Answer. No. You should stick with Scikit-Learn version 1.0.2. SAnDReS might work 

with a newer version of Scikit-Learn, but we know it works with version 1.0.2. 

 

 
16) Are there any executables for SAnDReS? 

 

Answer. No. During the development of this version, we generated working 

executables for Linux and Windows using auto-py-to-exe. But as soon as we moved 

to Scikit-Learn version 1.0.2, the executables we generated with this new version did 

not work anymore. We apologize, but you should follow the installation procedure 

described here (Section 3 and Section 4). We used auto-py-to-exe to generate our 

executables, but it did not work for Scikit-Learn 1.0.2. 

 

 
17) Can I apply SAnDReS to create a general scoring function? 

 

Answer. Yes. You may use as your dataset thousands of structures for which 

inhibition constant data is available, for instance. You may see Tutorial 4. Instead of 

limiting the search to structures to a specific protein, you may search the PDB for 

those with Ki data and insert the PDB access codes in SAnDReS and proceed as 

shown to generate machine learning models. 

 

 
18) Can I contribute to the development of SAnDReS? 

 

Answer. Yes. We welcome anyone interested in participating in this project. Please 

send an email mailto:sandres@azevedolab.net. 

 
 
 

19) Are there people using SAnDReS? 

https://github.com/azevedolab/sandres
mailto:sandres@azevedolab.net
mailto:sandres@azevedolab.net
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Answer. Yes. SAnDReS 1.0 had over 90 citations 

(https://scholar.google.com.br/scholar?oi=bibs&hl=pt- 

BR&cites=12867895474248966104). 

 
 
 

20) What is the 3D plot shown in Tutorial 1 (Section 5.9)? 
 

Answer. This plot shows intermolecular contacts involving ligands and protein in all 

structures in the dataset. We split into main-chain and side-chain contacts. Our goal 

is to identify possible patterns of ligand binding by analyzing these types of 

interactions. For instance, looking at side-chain atoms, we see Asp as the top 

residue, but with substantial contacts involving: Ala, Ile, Leu, Lys, Phe, and Val. We 

see a concentration of hydrophobic residues for contacts with side-chain atoms. 
 

 

Figure 61. Intermolecular contacts (Windows Version). 

https://scholar.google.com.br/scholar?oi=bibs&hl=pt-BR&cites=12867895474248966104
https://scholar.google.com.br/scholar?oi=bibs&hl=pt-BR&cites=12867895474248966104
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Figure 62. Intermolecular contacts (Windows Version). 

 
 

Looking at main-chain atoms, we see a peak for Leu. Such analysis helps to capture 

overall aspects of the intermolecular interactions. 

 

 
21) What is new in the SAnDReS 2.0? 

 

Answer. It is a new software with the same goal, to explore the Scoring Function 

Space using machine learning methods. SAnDReS 1.0 generated machine learning 

models based on nine regression models. Now we have 64 methods. SAnDReS 1.0 

used AutoDock Vina 1.1.2. Now we have the most recent version, AutoDock Vina 

1.2.3. There are a lot of minor modifications, but these previously highlighted are the 

most important ones. 
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11. GitHub 

SAnDReS source code is available to download on GitHub: 

https://github.com/azevedolab/sandres 

https://github.com/azevedolab/sandres
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14. Colophon 

We performed protein-ligand docking simulations and machine learning modeling 

reported on this User Guide using a Notebook with 4GB of memory, a 1 TB hard 

disk, and an Intel® Core® i3-7020U @ 2.30 GHz processor running Windows 10. 
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Appendix. Regression Methods 

On the following page, we have a description of all parameters used for each 

regression method available in SAnDReS. The values for these parameters are in 

the file misc/data/ml.in. Mostly, we keep the same names used in the Scikit-Learn 

manual. The exceptions are the parameters: rand_in+ and cv_in*. In the following 

table, we provide links for complete descriptions of the parameters for each 

regression method. 

Half of the regression methods available in SAnDReS use cross-validation (CV). 

We implemented the Kfold class from Scikit-Learn to perform cross-validation. 

Kfold class builds an n-fold cross-validation loop and tests the generalization ability 

of regression. Cross-validation is a better estimate of how well we could generalize 

to predict unseen data. 

Scikit-Learn provides some regression classes with built-in cross-validation 

implementation, e.g., ElasticNetCV. But this inclusion of built-in CV is not available 

for all regression methods (e.g., AdaBoostRegressor). Therefore, we adopted the 

same CV approach (Coelho & Richert, 2015) for the regression methods in 

SAnDReS 2.0. The MLRegMPy package has a class (ValidationLoop) that carries 

out CV for the 32 CV methods. 

Reference: Coelho LP, Richert W. (2015) Building Machine Learning Systems with 

Python. 2nd ed. Packt Publishing Ltd. Birmingham UK. 301 pp. See page 162 

(Cross-validation for regression). 

Before applying the regression methods, SAnDReS scales the data using the 

following methods available in Scikit-Learn: StandardScaler, MaxAbsScaler, 

MinMaxScaler, and RobustScaler. 

https://scikit-learn.org/stable/modules/generated/sklearn.preprocessing.StandardScaler.html
https://scikit-learn.org/stable/modules/generated/sklearn.preprocessing.MaxAbsScaler.html
https://scikit-learn.org/stable/modules/generated/sklearn.preprocessing.MinMaxScaler.html
https://scikit-learn.org/stable/modules/generated/sklearn.preprocessing.RobustScaler.html
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Regression methods available in SAnDReS.    
 

Method Cross 
Validation 

Parameters in ml.in file Default values for parameters in 
ml.in file 

Link 

AdaBoostRegressor None Regression method, 

base_estimator, 

n_estimators, 

learning_rate, loss, 

random_state 

AdaBoostRegressor,None,50,1 

.0,linear,None 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.AdaBoostRegr 
essor.html 

AdaBoostRegressorCV Kfold class Regression method, 

base_estimator, 

n_estimators, 

learning_rate, loss, 

random_state, cv_in* 

AdaBoostRegressorCV,None,50 

,1.0,linear,None,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.AdaBoostRegr 
essor.html 

ARDRegression None Regression method, 

n_iter, tol, alpha_1, 

alpha_2, lambda_1, 

lambda_2, compute_score, 

threshold_lambda, 

fit_intercept, copy_X, 

verbose, rand_in+ 

ARDRegression,1000,1e-3,1e- 

6,1e-6,1e-6,1e- 

6,False,10000,True,True,Fal 

se,1123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.ARDRegres 
sion.html 

ARDRegressionCV Kfold class Regression method, 

n_iter, tol, alpha_1, 

alpha_2, lambda_1, 

lambda_2, compute_score, 

threshold_lambda, 

fit_intercept, copy_X, 

verbose, rand_in+,cv_in* 

ARDRegressionCV,1000,1e- 

3,1e-6,1e-6,1e-6,1e- 

6,False,10000,True,True,Fal 

se,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.ARDRegres 
sion.html 

BaggingRegressor None Regression 

method,base_estimator, 

n_estimators, 

max_samples, 

max_features, bootstrap, 

bootstrap_features, 

oob_score, warm_start, 

BaggingRegressor,None,10,1. 

0,1.0,True,False,False,Fals 

e,-1,None,0 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.BaggingRegres 
sor.html 

https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.AdaBoostRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.ARDRegression.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
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  n_jobs, random_state, 

verbose 

  

BaggingRegressorCV Kfold class Regression 

method,base_estimator, 

n_estimators, 

max_samples, 

max_features, bootstrap, 

bootstrap_features, 

oob_score, warm_start, 

n_jobs, random_state, 

verbose, cv_in* 

BaggingRegressorCV,None,10, 

1.0,1.0,True,False,False,Fa 

lse,-1,None,0,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.BaggingRegres 
sor.html 

BayesianRidge None Regression method, 

n_iter, tol, alpha_1, 

alpha_2, lambda_1, 

lambda_2, alpha_init, 

lambda_init, 

compute_score, 

fit_intercept, copy_X, 

verbose, rand_in+ 

BayesianRidge,1000,1e-3,1e- 

6,1e-6,1e-6,1e- 

6,None,None,False,True,True 

,False,1123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.BayesianRi 
dge.html 

BayesianRidgeCV Kfold class Regression method, 

n_iter, tol, alpha_1, 

alpha_2, lambda_1, 

lambda_2, alpha_init, 

lambda_init, 

compute_score, 

fit_intercept, copy_X, 

verbose, rand_in+, cv_in* 

BayesianRidgeCV,1000,1e- 

3,1e-6,1e-6,1e-6,1e- 

6,None,None,False,True,True 

,False,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.BayesianRi 
dge.html 

DecisionTreeRegressor None Regression method, 

criterion, splitter, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

random_state, 

max_leaf_nodes, 

DecisionTreeRegressor,squar 

ed_error,best,None,2,1,0.0, 

None,None,None,0.0,0.0 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.tre 
e.DecisionTreeRegress 
or.html#sklearn.tree.De 
cisionTreeRegressor 

https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.BaggingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.BayesianRidge.html
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  min_impurity_decrease, 

ccp_alpha 

  

DecisionTreeRegressorCV Kfold class Regression method, 

criterion, splitter, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

random_state, 

max_leaf_nodes, 

min_impurity_decrease, 

ccp_alpha, cv_in* 

DecisionTreeRegressorCV,squ 

ared_error,best,None,2,1,0. 

0,None,None,None,0.0,0.0,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.tre 
e.DecisionTreeRegress 
or.html#sklearn.tree.De 
cisionTreeRegressor 

ElasticNet None Regression method, alpha, 

l1_ratio, fit_intercept, 

precompute, max_iter, 

copy_X, tol, warm_start, 

positive, random_state, 

selection, rand_in+ 

ElasticNet,1.0,0.5,True,Fal 

se,1000,True,1e- 

4,False,False,None,cyclic,1 

123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.ElasticNet.h 
tml 

ElasticNetCV Kfold class Regression method, alpha, 

l1_ratio, fit_intercept, 

precompute, max_iter, 

copy_X, tol, warm_start, 

positive, random_state, 

selection, rand_in+, 

cv_in* 

ElasticNetCV,1.0,0.5,True,F 

alse,1000,True,1e- 

4,False,False,None,cyclic,1 

123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.ElasticNet.h 
tml 

ExtraTreeRegressor None Regression method, 

criterion, splitter, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

random_state, 

min_impurity_decrease, 

max_leaf_nodes, ccp_alpha 

ExtraTreeRegressor,squared_ 

error,random,None,2,1,0.0,a 

uto,None,0.0,None,0.0 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.tre 
e.ExtraTreeRegressor. 
html 
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ExtraTreeRegressorCV Kfold class Regression method, 

criterion, splitter, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

random_state, 

min_impurity_decrease, 

max_leaf_nodes, 

ccp_alpha, cv_in* 

ExtraTreeRegressorCV,square 

d_error,random,None,2,1,0.0 

,auto,None,0.0,None,0.0,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.tre 
e.ExtraTreeRegressor. 
html 

ExtraTreesRegressor None Regression method, 

n_estimators, criterion, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

max_leaf_nodes, 

min_impurity_decrease, 

bootstrap, oob_score, 

n_jobs, random_state, 

verbose, warm_start, 

ccp_alpha, max_samples 

ExtraTreesRegressor,142,squ 

ared_error,None,2,1,0.0,aut 

o,None,0.0,False,False,- 

1,1123581321,0,False,0.0,No 

ne 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.ExtraTreesRegr 
essor.html 

ExtraTreesRegressorCV Kfold class Regression method, 

n_estimators, criterion, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

max_leaf_nodes, 

min_impurity_decrease, 

bootstrap, oob_score, 

n_jobs, random_state, 

verbose, warm_start, 

ExtraTreesRegressorCV,142,s 

quared_error,None,2,1,0.0,a 

uto,None,0.0,False,False,- 

1,1123581321,0,False,0.0,No 

ne,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.ExtraTreesReg 
ressor.html 

https://scikit-learn.org/stable/modules/generated/sklearn.tree.ExtraTreeRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.tree.ExtraTreeRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.tree.ExtraTreeRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.tree.ExtraTreeRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.tree.ExtraTreeRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.ExtraTreesRegressor.html


Appendix. Regression Methods 88 

 

 
 
 

  ccp_alpha, max_samples, 

cv_in* 

  

GaussianProcessRegressor None Regression method, 

kernel, alpha, optimizer, 

n_restarts_optimizer, 

normalize_y, 

copy_X_train, 

random_state 

GaussianProcessRegressor,No 

ne,1e- 

10,fmin_l_bfgs_b,0,False,Tr 

ue,None 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.ga 
ussian_process.Gaussi 
anProcessRegressor.ht 
ml 

GaussianProcessRegressorCV Kfold class Regression method, 

kernel, alpha, optimizer, 

n_restarts_optimizer, 

normalize_y, 

copy_X_train, 

random_state, cv_in* 

GaussianProcessRegressorCV, 

None,1e- 

10,fmin_l_bfgs_b,0,False,Tr 

ue,None,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.ga 
ussian_process.Gaussi 
anProcessRegressor.ht 
ml 

GradientBoostingRegressor None Regression method, loss, 

learning_rate, 

n_estimators, subsample, 

criterion, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_depth, 

min_impurity_decrease, 

init, random_state, 

max_features, alpha, 

verbose, max_leaf_nodes, 

warm_start, 

validation_fraction, 

n_iter_no_change, tol, 

ccp_alpha 

GradientBoostingRegressor,s 

quared_error,0.1,100,1.0,fr 

iedman_mse,2,1,0.0,3,0.0,No 

ne,None,None,0.9,0,None,Fal 

se,0.1,None,1e-4,0.0 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.GradientBoosti 
ngRegressor.html 

GradientBoostingRegressorCV Kfold class Regression method, loss, 

learning_rate, 

n_estimators, subsample, 

criterion, 

min_samples_split, 

min_samples_leaf, 

GradientBoostingRegressorCV 

,squared_error,0.1,100,1.0, 

friedman_mse,2,1,0.0,3,0.0, 

None,None,None,0.9,0,None,F 

alse,0.1,None,1e-4,0.0,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.GradientBoosti 
ngRegressor.html 

https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.gaussian_process.GaussianProcessRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.GradientBoostingRegressor.html


Appendix. Regression Methods 89 

 

 
 
 

  min_weight_fraction_leaf, 

max_depth, 

min_impurity_decrease, 

init, random_state, 

max_features, alpha, 

verbose, max_leaf_nodes, 

warm_start, 

validation_fraction, 

n_iter_no_change, tol, 

ccp_alpha, cv_in* 

  

HuberRegressor None Regression method, 

epsilon, max_iter, alpha, 

warm_start, 

fit_intercept, tol, 

rand_in+ 

HuberRegressor,1.35,1000,0. 

0001,False,True,1e- 

5,1123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.HuberRegre 
ssor.html 

HuberRegressorCV Kfold class Regression method, 

epsilon, max_iter, alpha, 

warm_start, 

fit_intercept, tol, 

rand_in+, cv_in* 

HuberRegressorCV,1.35,1000, 

0.0001,False,True,1e- 

5,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.HuberRegre 
ssor.html 

KernelRidge None Regression method, alpha, 

kernel, gamma, degree, 

coef0, kernel_params 

KernelRidge,1.0,linear,None 

,3.0,1.0,None 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.ker 
nel_ridge.KernelRidge. 
html 

KernelRidgeCV Kfold class Regression method, alpha, 

kernel, gamma, degree, 

coef0, kernel_params, 

cv_in* 

KernelRidgeCV,1.0,linear,No 

ne,3.0,1.0,None,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.ker 
nel_ridge.KernelRidge. 
html 

KneighborsRegressor None Regression method, 

n_neighbors, weights, 

algorithm, leaf_size, p, 

metric, metric_params, 

n_jobs 

KNeighborsRegressor,5,unifo 

rm,auto,30,2,minkowski,None 

,-1 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.nei 
ghbors.KNeighborsReg 
ressor.html 

https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.HuberRegressor.html
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KneighborsRegressorCV Kfold class Regression method, 

n_neighbors, weights, 

algorithm, leaf_size, p, 

metric, metric_params, 

n_jobs , cv_in* 

KNeighborsRegressorCV,5,uni 

form,auto,30,2,minkowski,No 

ne,-1,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.nei 
ghbors.KNeighborsReg 
ressor.html 

Lars None Regression method, 

fit_intercept, verbose, 

precompute, 

n_nonzero_coefs, eps_0#, 

eps_1#, n_samples# , 

copy_X, fit_path, jitter, 

random_state 

Lars,True,False,auto,500,0. 

25,1.00,50,True,True,None,1 

123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.Lars.html 

LarsCV Kfold class Regression method, 

fit_intercept, verbose, 

precompute, 

n_nonzero_coefs, eps_0#, 

eps_1#, n_samples# , 

copy_X, fit_path, jitter, 

random_state, cv_in* 

LarsCV,True,False,auto,500, 

0.25,1.00,50,True,True,None 

,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.Lars.html 

Lasso None Regression method, alpha, 

fit_intercept, 

precompute, copy_X, 

max_iter, tol, 

warm_start, positive, 

random_state, selection 

Lasso,0.65,True,False,True, 

1000,1e- 

4,False,False,1123581321,cy 

clic 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.Lasso.html 

LassoCV Kfold class Regression method, alpha, 

fit_intercept, 

precompute, copy_X, 

max_iter, tol, 

warm_start, positive, 

random_state, selection, 

cv_in* 

LassoCV,0.65,True,False,Tru 

e,1000,1e- 

4,False,False,1123581321,cy 

clic,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.Lasso.html 
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LassoLars None Regression method, alpha, 

fit_intercept, verbose, 

precompute, max_iter, 

eps, copy_X, fit_path, 

positive, jitter, 

random_state 

LassoLars,0.1,True,False,au 

to,500,0.25,True,True,False 

,None,1123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.LassoLars.h 
tml 

LassoLarsCV Kfold class Regression method, 

alpha, fit_intercept, 

verbose, precompute, 

max_iter, eps, copy_X, 

fit_path, positive, 

jitter, random_state, 

cv_in* 

LassoLarsCV,0.1,True,False, 

auto,500,0.25,True,True,Fal 

se,None,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.LassoLars.h 
tml 

LassoLarsIC None Regression method, 

criterion, fit_intercept, 

verbose, precompute, 

max_iter, eps, copy_X, 

positive, rand_in+ 

LassoLarsIC,aic,True,False, 

auto,500,0.25,True,False,11 

23581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.LassoLarsI 
C.html 

LassoLarsICCV Kfold class Regression method, 

criterion, fit_intercept, 

verbose, precompute, 

max_iter, eps, copy_X, 

positive, rand_in+, cv_in* 

LassoLarsICCV,aic,True,Fals 

e,auto,500,0.25,True,False, 

1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.LassoLarsI 
C.html 

LinearRegression None Regression method, 

fit_intercept, copy_X, 

n_jobs, positive, 

rand_in+ 

LinearRegression,True,True, 

-1,False,1123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.LinearRegre 
ssion.html 

LinearRegressionCV Kfold class Regression method, 

fit_intercept, copy_X, 

n_jobs, positive, 

rand_in+, cv_in* 

LinearRegressionCV,True,Tru 

e,-1,False,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.LinearRegre 
ssion.html 

LinearSVR None Regression, epsilon, tol, 

C, loss, fit_intercept, 

LinearSVR,1e-2,1e- 

8,1.0,epsilon_insensitive,T 

https://scikit- 
learn.org/stable/module 
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  intercept_scaling, dual, 

verbose, random_state, 

max_iter 

rue,1.0,True,0,1123581321,1 

000 

s/generated/sklearn.sv 
m.LinearSVR.html 

LinearSVRCV Kfold class Regression, epsilon, tol, 

C, loss, fit_intercept, 

intercept_scaling, dual, 

verbose, random_state, 

max_iter, cv_in* 

LinearSVRCV,1e-2,1e- 

8,1.0,epsilon_insensitive,T 

rue,1.0,True,0,1123581321,1 

000,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.sv 
m.LinearSVR.html 

MLPRegressor None Regression, 

hidden_layer_sizes, 

activation, solver, 

alpha, batch_size, 

learning_rate, 

learning_rate_init, 

power_t, max_iter, 

shuffle, random_state, 

tol, verbose, warm_start, 

momentum, 

nesterovs_momentum, 

early_stopping, 

validation_fraction, 

beta_1, beta_2, epsilon, 

n_iter_no_change, max_fun 

MLPRegressor,75,logistic,lb 

fgs,0.01,auto,adaptive,0.00 

1,0.5,200,True,1123581321,5 

e- 

3,False,False,0.9,True,Fals 

e,0.1,0.9,0.999,1e- 

8,10,15000 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.ne 
ural_network.MLPRegr 
essor.html 

MLPRegressorCV Kfold class Regression, 

hidden_layer_sizes, 

activation, solver, 

alpha, batch_size, 

learning_rate, 

learning_rate_init, 

power_t, max_iter, 

shuffle, random_state, 

tol, verbose, warm_start, 

momentum, 

nesterovs_momentum, 

early_stopping, 

validation_fraction, 

MLPRegressorCV,75,logistic, 

lbfgs,0.01,auto,adaptive,0. 

001,0.5,200,True,1123581321 

,5e- 

3,False,False,0.9,True,Fals 

e,0.1,0.9,0.999,1e- 

8,10,15000,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.ne 
ural_network.MLPRegr 
essor.html 
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  beta_1, beta_2, epsilon, 

n_iter_no_change, 

max_fun, cv_in* 

  

NuSVR None Regression method, nu, C, 

kernel, degree, gamma, 

coef0, shrinking, tol, 

cache_size, verbose, 

max_iter, rand_in+ 

NuSVR,0.5,1.0,linear,1,auto 

,0.0,True,0.001,200.0,False 

,-1,1123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.sv 
m.NuSVR.html 

NuSVRCV Kfold class Regression method, nu, C, 

kernel, degree, gamma, 

coef0, shrinking, tol, 

cache_size, verbose, 

max_iter, rand_in+, cv_in* 

NuSVRCV,0.5,1.0,linear,1,au 

to,0.0,True,0.001,200.0,Fal 

se,-1,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.sv 
m.NuSVR.html 

OrthogonalMatchingPursuit None Regression method, 

n_nonzero_coefs, tol, 

fit_intercept, 

precompute, rand_in+ 

OrthogonalMatchingPursuit,N 

one,None,True,auto,11235813 

21 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.Orthogonal 
MatchingPursuit.html 

OrthogonalMatchingPursuitCV Kfold class Regression method, 

n_nonzero_coefs, tol, 

fit_intercept, 

precompute, rand_in+, 

cv_in* 

OrthogonalMatchingPursuitCV 

,None,None,True,auto,112358 

1321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.Orthogonal 
MatchingPursuit.html 

PassiveAggressiveRegressor None Regression method, C, 

fit_intercept, max_iter, 

tol, early_stopping, 

validation_fraction, 

n_iter_no_change, 

shuffle, verbose, loss, 

epsilon, random_state, 

warm_start, average 

PassiveAggressiveRegressor, 

1.0,True,1000,1e- 

3,False,0.1,5,True,0,epsilo 

n_insensitive,1e- 

4,1123581321,True,True 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.PassiveAgg 
ressiveRegressor.html 

PassiveAggressiveRegressorCV Kfold class Regression method, C, 

fit_intercept, max_iter, 

tol, early_stopping, 

PassiveAggressiveRegressorC 

V,1.0,True,1000,1e- 

3,False,0.1,5,True,0,epsilo 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
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  validation_fraction, 

n_iter_no_change, 

shuffle, verbose, loss, 

epsilon, random_state, 

warm_start, average, 

cv_in* 

n_insensitive,1e- 

4,1123581321,True,True,5 

ear_model.PassiveAgg 
ressiveRegressor.html 

RandomForestRegressor None Regression method, 

n_estimators, criterion, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

max_leaf_nodes, 

min_impurity_decrease, 

bootstrap, oob_score, 

n_jobs, random_state, 

verbose, warm_start, 

ccp_alpha, max_samples 

RandomForestRegressor,142,s 

quared_error,None,2,1,0.0,a 

uto,None,0.0,True,False,- 

1,1123581321,0,False,0.0,No 

ne 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.RandomForest 
Regressor.html 

RandomForestRegressorCV Kfold class Regression method, 

n_estimators, criterion, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

max_leaf_nodes, 

min_impurity_decrease, 

bootstrap, oob_score, 

n_jobs, random_state, 

verbose, warm_start, 

ccp_alpha, max_samples, 

cv_in* 

RandomForestRegressorCV,142 

,squared_error,None,2,1,0.0 

,auto,None,0.0,True,False,- 

1,1123581321,0,False,0.0,No 

ne,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.RandomForest 
Regressor.html 

RANSACRegressor None Regression method, 

base_estimator, 

min_samples, 

RANSACRegressor,None,None,N 

one,None,None,100,np.inf,np 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
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  residual_threshold, 

is_data_valid, 

is_model_valid, 

max_trials, max_skips, 

stop_n_inliers, 

stop_score, 

stop_probability, loss, 

random_state 

.inf,np.inf,0.99,absolute_e 

rror,1123581321 

ear_model.RANSACRe 
gressor.html 

RANSACRegressorCV Kfold class Regression method, 

base_estimator, 

min_samples, 

residual_threshold, 

is_data_valid, 

is_model_valid, 

max_trials, max_skips, 

stop_n_inliers, 

stop_score, 

stop_probability, loss, 

random_state, cv_in* 

RANSACRegressorCV,None,None 

,None,None,None,100,np.inf, 

np.inf,np.inf,0.99,absolute 

_error,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.RANSACRe 
gressor.html 

Ridge None Regression method, alpha, 

fit_intercept, copy_X, 

max_iter, tol, solver, 

positive, random_state 

Ridge,1.0,True,True,None,1e 

-3,auto,False,None 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.Ridge.html 

RidgeCV Kfold class Regression method, alpha, 

fit_intercept, copy_X, 

max_iter, tol, solver, 

positive, random_state, 

cv_in* 

RidgeCV,1.0,True,True,None, 

1e-3,auto,False,None,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.Ridge.html 

SGDRegressor None Regression method, loss, 

penalty, alpha, l1_ratio, 

fit_intercept, max_iter, 

tol, shuffle, verbose, 

epsilon, random_state, 

learning_rate, eta0, 

power_t, early_stopping, 

validation_fraction, 

SGDRegressor,squared_error, 

l2,0.001,0.15,True,20000000 

00,1e- 

3,True,0,0.1,1123581321,inv 

scaling,0.01,0.25,False,0.1 

,5,False,False 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.SGDRegres 
sor.html 
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  n_iter_no_change, 

warm_start, average 

  

SGDRegressorCV Kfold class Regression method, loss, 

penalty, alpha, l1_ratio, 

fit_intercept, max_iter, 

tol, shuffle, verbose, 

epsilon, random_state, 

learning_rate, eta0, 

power_t, early_stopping, 

validation_fraction, 

n_iter_no_change, 

warm_start, average, 

cv_in* 

SGDRegressorCV,squared_erro 

r,l2,0.001,0.15,True,200000 

0000,1e- 

3,True,0,0.1,1123581321,inv 

scaling,0.01,0.25,False,0.1 

,5,False,False,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.SGDRegres 
sor.html 

SVR None Regression method, 

kernel, degree, gamma, 

coef0, tol, C, epsilon, 

shrinking, cache_size, 

verbose, max_iter, 

rand_in+ 

SVR,linear,1,scale,0.0,1e- 

3,1.0,0.1,True,200.0,False, 

-1,1123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.sv 
m.SVR.html 

SVRCV Kfold class Regression method, 

kernel, degree, gamma, 

coef0, tol, C, epsilon, 

shrinking, cache_size, 

verbose, max_iter, 

rand_in+, cv_in* 

SVRCV,linear,1,scale,0.0,1e 

- 

3,1.0,0.1,True,200.0,False, 

-1,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.sv 
m.SVR.html 

TheilSenRegressor None Regression method, 

Regression method, 

fit_intercept, copy_X, 

max_subpopulation, 

n_subsamples, max_iter, 

tol, random_state, 

n_jobs, verbose 

TheilSenRegressor,True,True 

,10000,None,300,1e- 

3,1123581321,-1,False 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.TheilSenRe 
gressor.html 

TheilSenRegressorCV Kfold class Regression method, 

fit_intercept, copy_X, 

max_subpopulation, 

n_subsamples, max_iter, 

TheilSenRegressorCV,True,Tr 

ue,10000,None,300,1e- 

3,1123581321,-1,False,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
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  tol, random_state, 

n_jobs, verbose, cv_in* 

 ear_model.TheilSenRe 
gressor.html 

TweedieRegressor None Regression method, power, 

alpha, fit_intercept, 

link, max_iter, tol, 

warm_start, verbose, 

rand_in+ 

TweedieRegressor,0.0,1.0,Tr 

ue,auto,100,1e- 

4,False,0,1123581321 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.TweedieRe 
gressor.html 

TweedieRegressorCV Kfold class Regression method, power, 

alpha, fit_intercept, 

link, max_iter, tol, 

warm_start, verbose, 

rand_in+, cv_in* 

TweedieRegressorCV,0.0,1.0, 

True,auto,100,1e- 

4,False,0,1123581321,5 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.lin 
ear_model.TweedieRe 
gressor.html 

VotingRegressor None Regression method, 

fit_intercept, copy_X, 

n_jobs, 

n_estimators, criterion, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

max_leaf_nodes, 

min_impurity_decrease, 

bootstrap, oob_score, 

n_jobs, random_state, 

verbose, warm_start, 

ccp_alpha, max_samples, 

weights, n_jobs, verbose 

VotingRegressor,True,True,- 

1,142,squared_error,None,2, 

1,0.0,auto,None,0.0,True,Fa 

lse,None,1123581321,0,False 

,0.0,None,None,None,False 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
semble.VotingRegress 
or.html 

VotingRegressorCV Kfold class Regression method, 

fit_intercept, copy_X, 

n_jobs, 

VotingRegressorCV,True,True 

,- 

1,142,squared_error,None,2, 

1,0.0,auto,None,0.0,True,Fa 

https://scikit- 
learn.org/stable/module 
s/generated/sklearn.en 
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https://scikit-learn.org/stable/modules/generated/sklearn.linear_model.TweedieRegressor.html
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  n_estimators, criterion, 

max_depth, 

min_samples_split, 

min_samples_leaf, 

min_weight_fraction_leaf, 

max_features, 

max_leaf_nodes, 

min_impurity_decrease, 

bootstrap, oob_score, 

n_jobs, random_state, 

verbose, warm_start, 

ccp_alpha, max_samples, 

weights, n_jobs, verbose, 

cv_in* 

lse,None,1123581321,0,False 

,0.0,None,None,None,False,5 

semble.VotingRegress 
or.html 

XGBRegressor None Regression method, 

booster, verbosity, 

validate_parameters, 

disable_default_eval_metr 

ic, eta, gamma, 

max_depth, 

min_child_weight, 

subsample, 

sampling_method, 

colsample_bytree, 

colsample_bylevel, 

colsample_bynode, lambda, 

alpha, tree_method, 

scale_pos_weight, 

refresh_leaf, 

process_type, predictor, 

objective, n_estimators 

XGBRegressor,gbtree,1,True, 

False,0.3,0.0,6,1.0,1.0,uni 

form,1.0,1.0,1.0,1.0,10.0,a 

uto,1.0,1,default,auto,reg: 

squarederror,100 

https://xgboost.readthe 

docs.io/en/latest/param 

eter.html#general- 

parameters 

and 

https://xgboost.readthe 

docs.io/en/latest/python 

/python_api.html 

XGBRegressorCV Kfold class Regression method, 

booster, verbosity, 

validate_parameters, 

XGBRegressorCV,gbtree,1,Tru 

e,False,0.3,0.0,6,1.0,1.0,u 

niform,1.0,1.0,1.0,1.0,10.0 

https://xgboost.readthe 

docs.io/en/latest/param 

https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.VotingRegressor.html
https://scikit-learn.org/stable/modules/generated/sklearn.ensemble.VotingRegressor.html
https://xgboost.readthedocs.io/en/latest/parameter.html#general-parameters
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https://xgboost.readthedocs.io/en/latest/python/python_api.html
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  disable_default_eval_metr 

ic, eta, gamma, 

max_depth, 

min_child_weight, 

subsample, 

sampling_method, 

colsample_bytree, 

colsample_bylevel, 

colsample_bynode, lambda, 

alpha, tree_method, 

scale_pos_weight, 

refresh_leaf, 

process_type, predictor, 

objective, n_estimators, 

cv_in* 

,auto,1.0,1,default,auto,re 

g:squarederror,100,5 

eter.html#general- 

parameters 

and 

https://xgboost.readthe 

docs.io/en/latest/python 

/python_api.html 

*cv_in variable holds an integer for the number of subsets used in the cross-validation process. 

+rand_in holds a dummy integer seed to be used to generate a Molegro Data Modeller (MDM) format file. 

#eps_0, eps_1, and n_samples define an array (eps) as follows: 

eps_array = np.linspace(eps_0, eps_1, num=n_samples_in) 

This is applied for machine-precision regularization in the computation of the Cholesky diagonal factors. 

https://xgboost.readthedocs.io/en/latest/parameter.html#general-parameters
https://xgboost.readthedocs.io/en/latest/parameter.html#general-parameters
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